Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my certifcate issued by "TC Trustcenter" in a CER file. Thunderbird 3.0 needs it as a PFX files. So I installed the CER certificate with the Internet options in the Control Panel. Thereafter I exported the certificate including the "private key" and "all certificates in the certification path" to a PFX file.

After importing this certificate with Thunderbird I still cannot decrypt the mail sent to the mail address of the certificate. What else must I do to use the private key? The certificate is valid since I decrypted the mail already on another computer using Outlook. I verified the certificate serial number to ensure that I use the same certificate.

share|improve this question
    
Is it there in Options / Advanced / Certificates / View Certificates / Your Certificates? –  Paul Dec 3 '11 at 12:33
    
Yes it is, except that I have a localized version of Thunderbird: Extras / Einstellungen / Erweitert / Zertifikate / Zertifikate / Ihre Zertifikate. It is listed here, and it will expire in November 2013. –  harper Dec 3 '11 at 12:49
    
Presumably thunderbird tells you the private key is there? SMIME emails are encrypted with your public key and the senders private key. So you need both your private key and their certificate to decrypt. Do you have a cert in the "People" tab corresponding with the source email address? –  Paul Dec 3 '11 at 13:03
1  
Clarifying a little: Normally .cer files only contain the public part of your certificate -- the private key has been stored by Windows directly, at time of sending the certificate request. –  grawity Dec 3 '11 at 13:04
    
@Paul: The sender's private key never takes part in encryption -- only signing, which is independent. Decryption should still succeed, since the signature cannot even be verified before that. –  grawity Dec 3 '11 at 13:04
add comment

3 Answers

Make sure your certificate is selected under Tools - Account Settings - Security - Encryption. It could be that Thunderbird is unable to detect the correct decryption certificate automatically.

share|improve this answer
    
I have several certificates here. But even when I have selected the correct certificate Thunderbird does not decrypt the mails. –  harper Dec 3 '11 at 15:39
add comment

You wrote that you installed the certificate using "Internet options in the Control Panel."

This the wrong place for installing a certificate, Thunderbird does not make use of the Windows certificate store - it has it's own certificate store.

In Thunderbird go to Tools -> Options... -> Advanced -> Certificates -> Manage Certificates... There you can import your certificate including the private key.

Afterwards encrypted mails be be decrypted.

See also: Installing an SMIME certificate

share|improve this answer
    
Yes I installed the certificate in the "wrong place". When you read the complete question you find what I did else.<br/> See:CER,PFX,Thunderbird. –  harper Dec 16 '11 at 17:54
add comment
up vote 0 down vote accepted

Microsoft Outlook and Thunderbird are incompatible by default. It's possible to fix Outlook, but there is no way to do the same when you are at the Thunderbird side.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.