Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do you associate the .exe file extension with a program in Windows?

I wanted to look at a shortcut or .exe file (not sure which, unfortunately) in Notepad, so I opened it right up (Open with ...).

Then I realized that I must have told the computer to always open such files with Notepad ... now everything is screwed up. Can't even figure out how to open the shell.

How do I undo this? Or have I already made a permanent change?


Similar to this question, but I'm not a power user, so I don't understand the answers. I thought this could be done through the control panel.

To make it more difficult, I'm on a french computer, and using Windows 7 (I think) which I'm not familiar with (always used XP).

share|improve this question

marked as duplicate by studiohack Dec 3 '11 at 17:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Also similar: superuser.com/questions/210670/… but the solution doesn't work. –  Matt Fenwick Dec 3 '11 at 16:08
    
Related solution: superuser.com/q/354771/24500 –  surfasb Dec 29 '11 at 13:03

1 Answer 1

up vote 1 down vote accepted

The answer I finally found after lots of googling was here:

What I did to correct.

Clear the association from the first two keys. My fun included a third key named something like user option or user choice(which I deleted).

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lnk\OpenWithProgids

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lnk\OpenWithList

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lnk\user option something

Note: I don't know if this is the best way, or if it's safe, or even if the entire problem is fixed. But as far as I can tell everything seems to be back to normal.


Here's what I did (as nearly as I can remember) for a non-poweruser:

  • click on the start menu, and in the search box type in "regedit"
  • open the application that it finds for you
  • in the program that opens, follow the path in the above post (HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lnk\OpenWithProgids)
  • delete the key mentioned above
  • exit
  • restart the computer
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.