Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As the question above "How do I disable the x window on Fedora 15" ? I search the question from ,and I got this article

   vi /etc/inittab

   Find out entry that read as follows:
   id:5:initdefault:

   Set the default runlevel to 3 (text mode)
   id:3:initdefault:

Save and close the file
reboot

However, when I open the file "inittab" on my Fedora 15 I only found these information in inittab:

inittab is no longer used when using systemd.

 ADDING CONFIGURATION HERE WILL HAVE NO EFFECT ON YOUR SYSTEM.

 Ctrl-Alt-Delete is handled by /etc/systemd/system/ctrl-alt-del.target

 systemd uses 'targets' instead of runlevels. By default, there are two main targets:

 multi-user.target: analogous to runlevel 3
 graphical.target: analogous to runlevel 5

To set a default target, run:

 ln -s /lib/systemd/system/<target name>.target /etc/systemd/system/default.target

How do I disable the X-Window?

share|improve this question

migrated from stackoverflow.com Dec 3 '11 at 16:34

This question came from our site for professional and enthusiast programmers.

3 Answers 3

This is directly from the Fedora Project wiki:

https://fedoraproject.org/wiki/Systemd#How_do_I_change_the_runlevel.3F

EDIT

Here are some details that will hopefully help you understand the process.

Fedora 15 and 16 use systemd. To change to the equivalent of the old runlevel 3, you must first remove the default target, which is the equivalent of the old runlevel 5. In order to do this, log in as root, and then do the following:

# cd /etc/systemd/system
system # rm ./default.target
system # 

Now, the targets are stored in the directory /lib/systemd/system/, and the equivalent of the old runlevel 3 is multi-user.target. You must now symlink that file to this current location with the name default.target:

system # ln -sf /lib/systemd/system/multi-user.target ./default.target

Reboot, and you should be good to go.

share|improve this answer
    
Could you explain it more perhaps, by editing your answer? We prefer more detail as opposed to linking. You can copy and paste it, if you credit the wiki –  Simon Sheehan Dec 3 '11 at 17:06
    
Sorry, I'm a bit late to respond to your comment. I guess DejanLekic beat me to it. –  Shredderroy Dec 3 '11 at 22:56
    
Feel free to answer anyway! It's fine to post it again in your own words even :) –  Simon Sheehan Dec 3 '11 at 23:28

As root do the following:

# remove the default systemd target, which is (probably) the graphical.target
rm /etc/systemd/system/default.target
# now, let's make the SystmV's runlevel 3 to be the default one
ln -sf /lib/systemd/system/multi-user.target /etc/systemd/system/default.target 
# switch back to graphical (SystemV runlevel 5)
ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target 
share|improve this answer

The easiest way to disable X Window is by editing grub boot loader /boot/grub/grub.conf and appending runlevel 3 (multiuser,network,no-gui) to your kernel line of the used stanza.

eg. Note the '3' at the end

title Fedora
root (hd0,0)
kernel /vmlinuz-2.6.18-274.7.1 ro root=/dev/VolGroup00/LogVol00 3
initrd ...
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.