Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When booting my computer (Debian Squeeze), the boot screen freezes almost immediately, but when I press a random key (including useless keys such as NumLock) the boot process continues. This happens several times during boot.

Once GDM shows up (requiring at least another key press) and I log in, the mouse changes to the "waiting" icon, stopping a couple times until Gnome starts up - from then on, the computer works normally... unless I try to switch to/from a console, in which case I have to (yeah, you guessed it) press a key. This also happens while using gnome-terminal (extra diagnosis: if I try cat /proc/cpuinfo, for instance, the command will hang the first time, but after that it will work flawlessly).

Finally, this happens too when shutting down the computer (it will show something as "Shutting down Samba", but it continues only after I press a key).

Any ideas about why could this be happening?

Important detail: Sometimes if I don't press any key, after about 15 seconds the system continues doing whatever it was trying to do at the moment. This happens usually when X is running, leading me to think that perhaps moving the mouse works as well as pressing the NumLock key. This would also explain why Gnome is not as fast as it should (slight delays showing menus, switching programs, and so on).

Not so important detail: I recently replaced console-tools for kbd, because some guy was reporting a slightly similar problem somewhere else, but it didn't work.

Extra info:

  • My computer has a 2.6.32-5-amd64 kernel.

  • The video card is an ATI Radeon, but the problem was present both before and after configuring xorg.conf to properly recognize it. Both the video card and the motherboard are Gigabyte.

  • The keyboard is PS/2 (I tried another PS/2 keyboard with no success, and I don't have any USB keyboard available). The computer works fine under Windows XP.

share|improve this question

1 Answer 1

Answering my own question: The problem was related to ACPI. Setting either acpi=off or cpi_skip_timer_override on GRUB solved the problem.

(giving credit where credit is due)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.