Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system used to play DVDs flawlessly. Now all of a sudden, it stutters. I have tested multiple commercial DVDs (standard definition, not HD), which are clean and not scratched. All of them stutter equally. Video files stored on the hard drive do not stutter, nor does Netflix.

My setup

  • Pentium 4 2.4ghz 4gb RAM
  • ATI Radeon 9200 video card
  • IDE DVD drive [ATAPI liteon]
  • Win XP SP3
  • Media Player Classic
  • XP codec pack

What I've checked/tried

  • No other applications are running on the system.
  • During DVD playback, CPU usage is low (60% at peak, usually below 30%)
  • I have checked that the DVD drive is in DMA mode.
  • Data transfer tests at 2.72 mb/s
  • I have tried uninstalling and reinstalling the codecs, MPC and VLC.
  • I have cleaned the lens on the DVD drive with a lens cleaner disc.
  • I can play mpg4 movie files from a data DVD without noticeable stutter

I have fooled with the config of ffdshow and managed to get it so that in Media Player Classic the video doesn’t stutter much, but the sound still stutters badly. The video and audio stutter are quite bad in both Windows Media Player and VLC.

Any suggestions? Thanks

share|improve this question
    
Is there any issue with data DVDs? What happens if you try to rip the DVD to the hard drive before playing? –  user55325 Dec 3 '11 at 22:39
    
What data transfer rate are you getting when you test between the DVD drive and the motherboard? –  steampowered Dec 3 '11 at 22:58
    
Could the motor on the DVD drive be bad? It would sound like it's a software problem or issue with the DVD Drive. Try booting from a USB LiveCD of Ubuntu and see if you still have problems. If you do, then you know it's probably your IDE DVD drive. Otherwise, it's a software issue in XP. –  kobaltz Dec 4 '11 at 0:17
    
Finally fixed it. Looking again at the settings in Device Manager, I noticed that the IDE channel was set to "DMA if available" but under mode it just said "not applicable." That sounded fishy, so I uninstalled the secondary IDE channel and re-installed. When the DVD drive came back, the mode was set to Ultra DMA 2. The stutter is gone. –  Kevin Dec 5 '11 at 8:16
add comment

1 Answer

If the problem is anything to do with codec which it does sound like, try this as a work around. Install and use VLC Media Player, plays anything/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.