Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my first attempt to write this question while I had the issue. Because of the issue, I was unable to click on the post question button:

I just woke my computer from sleep and my keyboard is not behaving.

For example, the modifier keys are reversed so pressing arrow left highlights text rather than moving the cursor. I also have my Caps Lock key reversed, and I get a < when I try to type a comma and a > when I type a fullstop, yet holding or not holding Shift does not correct this.

I have tried unplugging the keyboard and plugging it back in using a different USB port with no improvement.

In the past, the only solution I've found is to reboot the system. Else I'm stuck holding Ctrl to click on links so they don't open in new windows, etc.

After restarting my computer I'm tempted to put the punctuation in above. Basically, all the modifier keys Ctrl, Alt, Shift, Caps Lock had been reversed so that the lights and the key combinations did not work as expected, and using my computer became far more difficult. For example, I could click on some text, and click elsewhere, and it would select everything inbetween as if I had held the Shift key.

This has happened several times and always when I've woke my computer from sleep.

share|improve this question
    
That sounds weird! :) What kind of keyboard is it? –  Ƭᴇcʜιᴇ007 Dec 4 '11 at 0:44
    
It's a £2.99 standard UK layout USB keyboard I got from Argos, I've had it for years and it's worked perfectly fine, no fancy features, no backlit keys or media buttons, uses the standard Windows keyboard drivers –  Tom J Nowell Dec 4 '11 at 0:46
    
That reads to me like one of the shift keys is stuck down. Is there a behaviour that isn't accounted for by a stuck shift-key? –  Paul Dec 4 '11 at 4:12
    
yes, when I hold the shift key It does the reverse of what I would normally expect it to do. If it were stuck there would be no change when held down/rebooted. It also doesn't explain the capslock reverse, the alt key or the ctrl key –  Tom J Nowell Dec 4 '11 at 15:58
    
( on both sides of the keyboard too, not just the left/right ) –  Tom J Nowell Dec 4 '11 at 15:58
show 2 more comments

1 Answer 1

The feature that provides the functionality of what you are experiencing is called StickyKeys. It's not new to Windows 7, and it has been in since at least Windows XP that I know of, possibly earlier.

To disable in Windows 7: Menu Start -> Control Panel -> Ease of Access -> Change how your keyboard works (or make the keyboard easier to use) ->

All your settings are in here. I personally untick everything when I build a new PC. Make sure nothing is ticked and also go into setup StickyKeys and untick anything in here.

I cannot explain why coming out of sleep is causing this, but hopefully this should stop it from happening.

share|improve this answer
    
I play a lot of RTS games, which means sticky keys comes on a lot when holding shift to queue orders, so disabling sticky keys was one of the first things I did when I set up this machine –  Tom J Nowell Dec 14 '11 at 21:52
    
personally then I would re-install - I have no idea why this might be happening, especially if you've already disabled that. –  PrivateSniper Dec 15 '11 at 8:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.