Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On My Mac Mini (Tiger), I've enabled personal file sharing and windows sharing. From Windows 7, I am able to connect to the Mini just fine and I can manipulate the files. However, I also have an attached storage device (WD My Book) attached to the Mac Mini that I cannot figure out how to get at. The drive icon sits on my Mini's Desktop, so I figured I would navigate to the desktop folder from Windows...but I don't see it.

When I connect to my Mini via my MacBook (Leopard), it gives me the options to mount the Macintosh HD, My Book, and the user account.

Can somebody help me figure out how to access that Mini-mounted external storage device from Windows?

Thanks!

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

This is an aspect of OS X that received massive attention in the move from Tiger to Leopard. And it needed it, badly!

OS X 10.4 Tiger does have full windows file sharing support through SAMBA under the hood, but there is no GUI to it. If you're comfortable on the terminal you can configure any share you like. Here's a link with some details: http://www.playingwithwire.com/2007/03/unleash-the-power-of-samba-under-os-x/

There may be GUIs out there by third parties, but there's no way to do this from the System Preference pane on Tiger. When I used Tiger I looked into finding a GUI and never did find one, I ended up using the terminal to set up my shares.

Bart.

share|improve this answer
    
Perfect! Thanks for helping me out. –  Tim Reddy Sep 30 '09 at 19:41
add comment

You need to add the external drive as a shared volume as well. It should be in the windows sharing options.

share|improve this answer
add comment

You'll need to be connecting to the Mac as an Admin User for external drives to show up as share points

share|improve this answer
add comment

Just like Windows, you will need to specify explicitly that you want to share the external hard on your network. Luckily enough, this is simple to do:

  • In System Preferences, select "Sharing" and make sure "File Sharing" is ticked.

    enter image description here

  • Select "File Sharing", and click the plus icon underneath "Shared Folders" and select your external hard drive.

    enter image description here

  • As of right not, your hard drive is shared, but it is read only on the network. To fix this, just change the permissions of "Everyone" to "Read and Write"

    enter image description here

share|improve this answer
    
I don't believe Tiger allows me to specify folders...at least I've never been able to find that capability. Leopard, OTOH, looks like the screenshots you provided. –  Tim Reddy Sep 6 '09 at 22:03
    
This is a great answer for Leopard users, but alas, this interface does not exist yet on Tiger. –  Bart B Sep 23 '09 at 10:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.