Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed virtual box 4.1.6 and vagrant-0.8.8 on my mac osx 10.6 box. When I run vagrant it complains that virtual box isn't installed. Any idea how I tell vagrant where virtual box is?

This is how I've installed everything:

vagrant:

$ sudo gem install vagrant
Successfully installed vagrant-0.8.8

virtual box gem:

$ sudo gem install virtualbox
Successfully installed virtualbox-0.9.2

virtual box itself:

$ curl -O http://download.virtualbox.org/virtualbox/4.1.6/VirtualBox-4.1.6-74713-OSX.dmg

.. installed via GUI ...

$ /Applications/VirtualBox.app/Contents/MacOS/VirtualBox --help | grep Manager
Oracle VM VirtualBox Manager 4.1.6

and finally, the error Virtualbox is giving:

$ vagrant
Vagrant could not detect VirtualBox! Make sure VirtualBox is properly installed.
If VirtualBox is installed, it may be an incorrect version. Vagrant currently
requires VirtualBox 4.1.x. Please install the proper version to continue.

If you have an older or newer version of VirtualBox, please make sure you're
using the proper version of Vagrant. Ask the mailing list if you have questions.

I've grep'ed through the virtualbox gem for any paths:

$ grep -R "Contents/MacOS" *
lib/virtualbox/com/ffi_interface.rb:          lib_path ||= "/Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMC.dylib"
lib/virtualbox/lib.rb:            @@lib_path = Dir.glob("/Applications/{,MacPorts/}VirtualBox.app/Contents/MacOS/VBoxXPCOMC.dylib")
test/virtualbox/lib_test.rb:      result = ["/Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMC.dylib"]

This file does exist on my system:

$ ls -alh /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMC.dylib
-rwxr-xr-x  1 root  admin    93K  4 Nov 12:38 /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMC.dylib

I've seen this issue on github: https://github.com/mitchellh/vagrant/issues/562 which has other people within the past two weeks with this issue. It mentions the previous person's version of the vargrant gem was out of date but I'm using 0.8.8.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I had the same problem. I solved it by running vagrant with sudo :

sudo vagrant
share|improve this answer
    
that might mean that your user has not been added to the vboxusers group - which you need to do manually –  Journeyman Geek Dec 6 '11 at 11:34
    
Thanks, I'm not sure why chmod a+rx wasn't enough but that's working. Thanks. –  Mark L Dec 8 '11 at 16:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.