Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Having slight issue with my Lion install. I removed the password from the admin account as it's not desired. However when I'm on the login screen, it wont accept the blank password. It shows the user account and a password box, and when you enter wrong password it gives you the hint.

The only way I've found to get in is by constantly spamming the user icon until it logs in.

Has anybody else experienced this or knows of a fix?

share|improve this question
    
It is not usually possible to use a blank password for an admin account., so it appears you're using an unsupported configuration and shouldn't wonder why it doesn't work. –  Daniel Beck Dec 4 '11 at 19:51
    
Some password prompts in the shell (such as those displayed by sudo by default) shouldn't accept an empty password either. –  ؘؘؘؘ Dec 5 '11 at 4:11
    
I don't understand why you wouldn't want an password on an admin account. Are you hoping to get hacked, or are you hoping to shoot yourself in the foot, or are you thinking you'll be able to dodge both of those bullets? –  Spiff Dec 5 '11 at 6:38
    
well all I did was go into Users & Accounts, removed the pass. and it works, when system changes are being made the prompt comes up to login, i can just hit enter. and it accepts the blank password happily. also when inside terminal i can use sudo, when it asks for password i just hit return and it logs in happily also. and the reason i don't want a password is. Im not precious with the data on here, if anybody was to steal it then all they need to do is google "reset password osx" and put a disc in. and they have access anyway. hardly worth it no realistic beneficial scenario i need one for. –  Owen Melbourne Dec 5 '11 at 13:24
    
Neither of the two usual options for resetting the login password resets the keychain password though. (It's separate from the login password even though they are usually the same.) I still can't get an empty password to work in the shell. –  ؘؘؘؘ Jun 20 '12 at 5:17

4 Answers 4

I clicked on my user icon above the password box and it let me in. Somewhat unexpected functionality if you ask me.

share|improve this answer

From your comment it seems you removed the password to be able to use sudo without a password.

If this is your reason you choose the wrong solution: you can easily configure sudo not to ask for a password:

$ sudo visudo

and then add

yourusername   ALL= NOPASSWD: ALL

see man sudoers

share|improve this answer
up vote 0 down vote accepted

I found out, by re running the setup assistance, and unticking the "require password on login" box that it fixed the issue and didnt ask for a password anymore!

share|improve this answer
    
You could've also just enabled automatic login in the login options section of the Users & Groups preferences. –  ؘؘؘؘ Jun 20 '12 at 5:18

I fixed this, but there was a workaround to get in so I could fix it.

To get in, I had to click the user icon twice. Once in, I went into the user accounts preference pane and clicked Login Options. There, I disabled the Show Password Hints setting. Now, pressing return at the login prompt works as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.