Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This error popped up in Windows 7 Home Premium when I right clicked an exe file on my desktop and selected "Run as Administrator". What would cause this? How can I run this file? Is this error referring to files this exe is trying to open or this exe itself?

Error: Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.

enter image description here

share|improve this question

3 Answers 3

Check the permissions of the C:\Users{your username}\Desktop folder by navigating to C:\Users{your username} (or click on your username from the Start Menu), right clicking, and selecting the Security tab.

If you were able to do this before, but suddenly can't, malware may be the cause. Also, if you copied a backup of your Desktop folder from somewhere else, as a different user, it may still have "old" permissions on it.

share|improve this answer
    
the administrator user has full allow access to everything in *\Desktop\ except "special permissions". I copied this file from my other computer via a shared folder if that is helpful? –  MacGyver Dec 4 '11 at 21:51
1  
I believe the exact mechanics of the "Run As Administrator" option have changed since XP. Anyway I would, as the your username, take ownership, which should work if you are in the Administrators group (local admin), and then give your username Full Control over it. –  ultrasawblade Dec 4 '11 at 22:44
    
i'll give you an up-vote for helping –  MacGyver Dec 9 '11 at 6:34

You need to add the account INTERACTIVE to the icons you copied over. Your account only has delete permissions.

This is to prevent programs that run under the user account from bombarding the desktop with icons. With the INTERACTIVE account, only someone logged into the console has access to the desktop.

share|improve this answer
    
I added INTERACTIVE to the list of users on that file under the security tab and checked each box (to give full access). The same error popped up. Then I tried copying it from the shared folder again to my c:\users\{username}\downloads\ folder, and got the same error. I got around it by just double clicking it from the shared folder. I'm sure i'll run into this issue again while installing things. If you have any more ideas, let me know. –  MacGyver Dec 5 '11 at 6:40
    
INTERACTIVE is not limited to just the console -- it's also assigned to Remote Desktop sessions. –  grawity Dec 5 '11 at 8:07
    
@grawity: Makes sense. –  surfasb Dec 5 '11 at 8:09
    
upvoted you for helping.. –  MacGyver Dec 9 '11 at 6:38
up vote 0 down vote accepted

This can happen from a lot of different things, but this is what was blocking access for me:

Microsoft Security Essentials (MSE)... I had to clear out the file list in the security essentials so it prompted me to choose the action (allow/block) for the file..

Copy file from shared folder onto desktop > double click file .. or simply run it from the shared folder. No permission changes to the file are necessary.

If the file is a new file to MSE, it'll ask you to block or allow. I chose allow. Then choose yes to the Windows 7 prompt to allow the file to run.

===============

I did learn some things. Windows 7 Home Premium is useless. You can't access the Microsoft Management Console to add the User/User Group snap-in to add/remove users to Wiindows user groups. This is irrelevant to my answer, but it will help someone who is messing with tools/services in Windows 7 Home Premium that don't have access to certain groups. So in order to see user groups and users it has to be done from the command prompt.

See groups:
net localgroup

See users in a group:
net localgroup Users (this is an example of how to find the INTERACTIVE user from a previous answer)

add user to user group:
net localgroup {usergroup} {username} /add

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.