Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to play a sound and talk on Skype at the same time. The problem is that Skype seems to be blocking the line, so when I am on Skype talking to someone and playing a game, the sounds from the game doesn't come at my phones, instead they are played from my notebook speakers... When the call is over the sound come back to my headphones.

Is there a configuration to change it? I want to hear both peoples voice and game sounds on the same device (on my phones)...

Repro steps:

  1. Have a headphones plugged
  2. Configure Skype to use the headphones
  3. Start a music
  4. Make a call

Result: The music will be played on another device and skype will take the primary device for the call blocking other sounds on this device.

Expected result: Both sounds to come from the same device.

My sound configurations are like this

config

I cannot set the default device as Independent Dual Headphones, the system doesn't allow me. The other option is Speakers and Dual Headphones. I think this device is a problem, I think I need to somehow disable the speakers or find a way to run an application in a way it will use the Independent Dual Headphones instead. What can I do?

Related:

share|improve this question
    
Not just in a call, whenever Skype plays a sound it changes the output of other sounds as well.\ –  BrunoLM Dec 11 '11 at 13:52
    
I have noticed that skype turns my other sounds lower, but not that it disables them or sends them through another output. You could maybe try to turn your speakers off in compmgmt.msc, under the device manager tab. –  Simon Verbeke Dec 11 '11 at 14:38
    
Have you checked the communications tab on that Sound window of Windows? –  Mavromatis Lozay Mar 31 '12 at 16:12

4 Answers 4

up vote 3 down vote accepted

To play all sound on one device do the following:

Open Skype preferences under Tools -> Options -> Audio settings
Select "Speakers/Headphones" as Speakers.
Select "Use selected speaker" as Ringing.
Uncheck "Automatically adjust speaker settings" for Speakers.


More details are here:

http://community.skype.com/t5/Windows/Does-your-music-alert-sounds-play-through-speakers-when-you-do-a/td-p/484041

share|improve this answer

Deactivate "independent dual headphones"

This makes your standard sound system control of device you have.

share|improve this answer

One cannot stream an mp3 music file when using Skype so the other person in the call could listen to it, because Skype doesn’t allow extra sound channels to interfere with the audio call.

To solve this problem, you require a third-party product that integrates with Skype.

One such products is PrettyMay, whose free Basic version does :

Play recorded calls/voicemails/audio files (.mp3 or .wav format) in conversations.

But it also does other functions, such as recording calls.

share|improve this answer

I had the same problem. Try: Tools -> audio settings ->

speakers settings as 'speakers and headphones', then uncheck 'automatically adjust speaker settings' ringing settings as '(communication/ dual / whatever type) headphones'

Hope this works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.