Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my machine (Lenovo ThinkPad w510, Ubuntu 10.10) I have (at least) two logical partitions:

  • an ext4 partition to which Ubuntu is installed;
  • a FAT32 partition (the bigger one) on which I store all my working data.

For some strange reason, the default file permissions on these partitions differ.

For example, when I download rebar from its git repository, there is different behaviour after I do git clone https://github.com/RJ/erlang_rebar_example_project.git:

  • on ext4 partition I just do cd rebar && make and it works;
  • on FAT32 I can not do make, because all the files inside the cloned rebar folder have the following permission: -rw-r--r--. If I do sudo chmod 777 -R rebar the file permissions don't change.

What is wrong here?

share|improve this question

1 Answer 1

-rw-r--r-- isn't the real set of attributes. FAT32 only has RHSA, Read-Hidden-System-Archive. Ubuntu maps those to "similar" Unix attributes depending on mount options. You can explicitly set this mask with the umask= mount option. (There's also a dmask for directories only and fmask for files only).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.