Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried reseting the winsock

netsh winsock reset

and tcp/ip

netsh int ip reset

But I still get this error.. I even cleared the win7 update Directory

C:\Windows\SoftwareDistribution

I need to update to Windows 7 ServicePack1 to run Adobe CS5

The size of SP1 in windows update utility is smaller than the one available on the microsoft's download center.

Can anyone help me with this error?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The Win 7 SP1 Windows Update offers is a "Stub installer", it will download the rest of hte service pack as it installs, whereas the one in the Download Center is (probably) the complete SP1 image.

Download the full version and try it.

Microsoft has a page devoted to Windows 7 SP1 install problems: http://windows.microsoft.com/troubleshootwindows7sp1

Here's some advice on things to try to increase the chances of SP1 installing properly.

Blurb:

  1. Check your available disk space - For now the best information available is as follows:
  2. Run Disk Cleanup.
  3. Create a new System Restore point just prior to installing SP1.
  4. If at all possible create an Image Backup of the Windows drive or partition.
  5. Install the Windows 7 device drivers for your make and model of computer, graphics adapter and other add-in cards.
  6. Disable AV Software.
  7. Run the SFC /SCANNOW command.
  8. Run the System Update Readiness Tool.
  9. Rename the 'Software Distribution folder'
  10. Check your Power Plan configuration.
  11. Perform a “Clean Boot” to prevent other programs for interfering with the installation process.
  12. Laptop users should connect their computer to AC power.

Lastly, MS provides free support for installation problems with SP1. Check out your support options with MS, here.

share|improve this answer
add comment

The error code 80072F78 signals a certificate that is either expired or "from the future".

To solve this problem, you have to make sure that your time and date are properly set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.