Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Used synergy 1.3.1 & 1.3.4 since 2007 without a hitch. Upgraded to Windows 7, and synergy suddenly stopped connecting after a week. Now any version I try (1.3.1, 1.3.4, 1.3.8, 1.4.5) goes into high CPU usage, no TCP connection makes it through, synergys process uses "Realtime" priority on install. Windows Firewall is open. Tried removing ipv6. Only way to get a TCP connection to go through is to enable "XP SP3 compatibility mode" and "Run as Administrator"... although that's not enough to get keyboard/mouse sharing to work.

share|improve this question
Did you install the correct version (32/64bit)? You don't mention it in your question and it's a pretty important part of troubleshooting... – Not Kyle stop stalking me Dec 5 '11 at 21:49
@Kyle - I tried both actually. The OS for my synergy server is 64bit, the first few tries with 1.4.5 and 1.3.8 were with 64bit. Dunno if you know the answer to those, but I was wondering quite a few things when troubleshooting: 1. does the 32bit server work properly on a 64bit os? 2. Is the protocol sensitive to 32/64bit (ex. does the 32bit client work ok with 64bit server)? 3. How much does the protocol change across synergy revision - will I run into problems when troubleshooting my Win7 server+Win7 client if I have my other clients still connected on the same subnet (MacOS + Linux)? – Christian Dec 6 '11 at 17:12
@Kyle - 4. Does my old *.sgc configuration file from 1.3.4 still work with 1.4.5? The new interactive configuration interface don't offer the same options as I used to do (IP addresses as aliases, screens split at a percentage value). 5. How good is the support for ipv6 vs ipv4, does it have any impact on the protocol and/or how to connect & identify the server/clients? -- Cheers, Christian – Christian Dec 6 '11 at 17:46
Two questions that may help me start troubleshooting: 1. Is this the right place to ask Syngergy questions? is listed on top of the list of support resources on the Synergy website, however I'm not sure if it's the primary resource traffic-wise. 2. Short of single-stepping in the code, what would be the best way to troubleshoot this? I see nothing of interest in the logs, no indication that client or server can talk to one another, and no explanation why the CPU goes hard to 50% as soon as I start my Synergy server. – Christian Dec 12 '11 at 17:03
Solved. Using Synergy 1.4.5, CMSWindowsKeyState::getIDForKey() went into an infinite loop if a Persian keyboard was installed on my system. Uninstalled that keyboard layout, and synergys.exe now works fine. – Christian Jan 2 '12 at 3:56

Make sure scroll lock is not active! I had a similar problem and ended up here (though the connection was working), deactivating scroll lock solved it!

share|improve this answer
Had this same issue happen with 1.4.16. Scrollock was the culprit. – Cow King Sep 29 '14 at 8:25

whenever synergy is not working always close bonjour from the task manager and then restart server and client. Go once again to clients task manager --> services. right click--> start. then when you click on autoconfig in client bonjour reinstalls. click on autoconfig and then synergy might start working. Synergy is not really user friendly (windows version atleast). I struggled without knowing why eventhought it connected to server it was not working.

share|improve this answer
Bonjour has nothing to do with Synergy. "synergy might start working" doesn't sound like an answer, more of a guess. – DavidPostill Apr 30 at 21:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.