Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was watching a YouTube video a while ago and my computer blue screened. I though nothing of it at start, but whenever I watch any video (basically anything that gets rendered (haven't tried games though)) after a period of time it blue screens. However, every time it seems to be different, occasionally it lasts a few minutes other times a few hours.

It only occurs with videos, say if I listen to music on Bandcamp, Grooveshark etc. It's fine, and the computer never blue screens.

After that, I was assuming that its a buggy flash version so I updated it, though it still seemed to blue screen. However, due to computer settings I wouldn't see the actual blue screen, it would just give me the Windows has recovered from a serious error message after login. So I changed the settings to I can see the actual blue screen.

When the computer blue screened again, I saw the driver causing the issue. It was nv4_disp.dll, however I just updated the Nvidia driver to the latest version, so I was under the impression that it is still flash causing the issue.

However, after trying basically everything to rectify it, nothing seems to help. I even tried changing browser, though it didn't even make the slightest difference.


More information:

OS: Windows XP Professional SP 3
Graphics Card: GeForce 9400 GT
Driver version: 285.58 (It says its the latest)

Blue screen dump file info:

Bugcheck name: KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (0x1000008E)
Another bugcheck name: THREAD_STUCK_IN_DEVICE_DRIVER (0xEA)
Caused by: nv4_disp.dll
share|improve this question
1  
If the error is connected to nv4_disp.dll then its not a bad flash installation. My guess your some combination of events causes your system to perform something unsupported by your current hardware. What operating system do you use? –  Ramhound Dec 6 '11 at 12:22
1  
I would suggest it's a graphics hardware issue - check your cooling & fans etc if a Laptop as it sounds like a classic overheating symptom. –  HaydnWVN Dec 6 '11 at 12:26
    
@Ramhound Added more info. –  Adam Dec 7 '11 at 8:44
    
@HaydnWVN I'm almost sure that its not overheating, however the CPU overheats a little when the room gets too warm, but the graphics card stays at about 50-60 degrees. –  Adam Dec 7 '11 at 8:49
    
I tend to use whocrashed for stuff like this. It tends to give somewhat more human friendly crash analysis –  Journeyman Geek Dec 7 '11 at 8:51

2 Answers 2

up vote 1 down vote accepted
+100

Sometimes it helps to disable hardware acceleration.

Follow these steps:

  1. Right-click on desktop and choose Personalize
  2. Click on Display
  3. Click on Change Display Settings
  4. Click Advanced Settings
  5. Click the Troubleshoot Tab
  6. Click Change Settings (if it's not grayed out; mine is)
  7. Move the Hardware acceleration slider towards none to reduce or turn off video hardware acceleration.
  8. Click OK, and then click Restart Now.

If it is grayed out: The problem may be with the ATI or Nvidia installed drivers. You would have to remove the installed video driver and use the generic Windows video driver to disable the hardware acceleration.

[EDIT]

As you do not wish to disable hardware acceleration, the thread BSOD with NV4_Disp.dll error contains the following suggestions :

  1. If using a graphics card that is factory overclocked - replace the card by one that is not overclocked
  2. Weak power supply - try removing CD/DVD drives and see if the problem improves
  3. RAM problem - test the memory using memtest86.

This thread suggests better scrubbing of the Nvidia drivers before reinstalling them. This other thread also suggests installing the latest DirectX version before that. I would add to that the advice of doing a full patch of Windows (including optional updates).

I remark that XP only supports DirectX 9, while upgrading to Windows 7 will get you the much better DirectX 11 (might require a newer video card).

share|improve this answer
    
I don't want to disable hardware acceleration globally because only flash causes the issue. –  Adam Dec 11 '11 at 22:21
    
I have added some more ideas. –  harrymc Dec 12 '11 at 8:55
1  
You can also disable hardware accelleration on the Flash player itself. Just right-click on the flashplayer, click settings, in the first tab uncheck the checkbox. –  ZippyV Dec 12 '11 at 15:23
    
One of the linked sites in the above question suggested this. –  Adam Dec 14 '11 at 2:54

As I have explored about this problem, I got some sort of discussions that seriously shown this problem with the flash player with the Nvidia drivers. Finally i got some troubleshooting steps to try and reason may be.

Check these links for know more about this:

http://www.geekstogo.com/forum/topic/287742-xp-bsod-watchdogsys-and-nv4-dispdll/
http://hardforum.com/showthread.php?t=1527315

Check this nvidia forum link regarding this problem.

share|improve this answer
1  
This seems to work. I'll do some more testing but so far, works fine. –  Adam Dec 11 '11 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.