Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know how it happened, but when I right-click on a folder, the "open" action doesn't show up any more. Instead of this, I have the default action set to "Read with windows player".

How can I recover the "open" action ?

share|improve this question

1 Answer 1

  1. In the Windows 7 Start Menu, right click on the Windows Explorer shortcut (typically store inside All Programs -> Accessories) and then select Properties.

  2. In the Target text box under Shortcut tab, change the value to one of the following to open either Documents or Computer by default.

    • To make Explorer the default enter:

      %windir%\explorer.exe
      
    • To make Documents the default folder to open in Windows Explorer upon launching:

      %SystemRoot%\explorer.exe /n,::{450D8FBA-AD25-11D0-98A8-0800361B1103}
      
    • To make Computer the default folder to open in Windows Explorer upon launching:

      %SystemRoot%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
      
  3. Click OK when done.

Windows 7 Explorer will now open Documents or Computer directly, skipping and bypassing Libraries, depends on what you set or configure on initial run. There are more special objects and folders that Windows Explorer can open directly to.

Windows XP

Try this

Open My Computer window. • Click Tools, Folder Options, then click File Types.

• From the list, locate the entry FOLDER with extension of (NONE).

• Click Advanced, select Explore, then Set Default

• Click OK and close the dialog. To accomplish this via the Registry: •Open Regedit.exe and navigate to: HKEY_CLASSES_ROOT\Folder\shell

•In the right pane, set the value of (default) to explore

share|improve this answer
    
Sorry, I didn't mention it was on Windows XP. –  TheBens Dec 6 '11 at 13:32
1  
Sorry it was tagged XP –  Kevin Dec 6 '11 at 15:38
1  
@Kevin this should be an answer. –  Moab Dec 6 '11 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.