Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two routers at home. One is standard router that is linked to my modem, the other is a WiFi router that also has additional ports. The WiFi router is connected to the first one. I have this setup for security reasons, as I was told that this would be more secure.

But sometimes when this WiFi router is connected, I lose the Internet connection (whether the connection to the modem fails or maybe somthing else goes wrong, at least the Internet connection doesn't work). After I power them both off for a minute or two and then power on again, then everything works.

Can this WiFi router be the reason for these failures?

PS: It is secured with WPA and I am not aware of anyone hacking my router(s) or network.

Update:
I have non-WiFi D-Link DI-604 router and WiFi Asus WL-530gV2. D-Link is connected to modem and Asus is connected to D-Link. I'm using the default firmware that came on the routers from the factory.

Today, when I powered on my PC, the connection was down again. At the moment I have disconnected the Asus (WiFi) router. So far so good.

Update 2:
PC is connected to router 1, not over WiFi since it is non-WiFi router. PC has IP 192.168.0.xxx and he receives it from router 1 and Android device after connection to WiFi router gets IP 192.168.1.xxx

Update 3:
Such scheme is better due to that all PCs at home connect to non-WiFi router and WiFi router is connected to non-WiFi router, so it mostly doesn't interact with home PCs.

share|improve this question

migrated from serverfault.com Dec 6 '11 at 13:55

This question came from our site for professional system and network administrators.

1  
I don't know anyone who would like to hack in at my house to use this connection. Just because you don't know who would doesn't mean there aren't any. Still, WPA is better than WEP...or nothing at all. –  tombull89 Dec 6 '11 at 13:42
    
Guys, please. On the topic. –  Eugene Dec 6 '11 at 13:55
    
At this point, there isn't enough information. Next time you experience Internet connection loss, try finding out more details for the connection loss. E.g. is nonWifi router still connected? –  bbaja42 Dec 6 '11 at 14:49
    
What more information is needed? I could update question. No, they both loose connection. –  Eugene Dec 7 '11 at 9:43
    
@Eugene: It was very hard for us to understand what your current WiFi set-up exist of or which set-up you are looking for, given that you described nowhere in your question about what you actually mean with that security. Until this point, we all kept suggesting suggestions (as well as your initial set-up) that actually don't provide that extra security; it was after digging down all the comments, that I finally understood what you are really after... –  Tom Wijsman Dec 15 '11 at 14:32
add comment

6 Answers

up vote 5 down vote accepted
+50

Table of contents:

  1. How do I put two routers in the same network?

  2. How do I make my wired computers inaccessible from wireless?

Choose the one that you would want, I think you want option 2 so scroll down.

How do I put two routers in the same network?

Note: In terms of security this set-up gives the same results as having just one wireless router.

 INTERNET                           Schematic: Both routers in the same network.
    |                                        
____|____
|       |
| MODEM |                                        
|_______|                     Not connected!     
    |                            |               
 ___|WAN______                ___|WAN______      
|             | DHCP SERVER  |             | DHCP SERVER
| HOME ROUTER | ENABLED.     | WIRELESS R  | DISABLED!
|_____________| OWN IP: .0.1 |_____________| OWN IP: .0.254
    |LAN1  |LAN2              |LAN1 :WIFI
    |      |__________________|     :     Note: This is the correct way to put
 COMPUTER                       ANDROID         two routers in the same network,
 DHCP ON.                       DHCP ON.        some routers can just bridge the
                                                WAN connection with the WiFi...

The following steps have to be performed:

  1. Disconnect everything.

  2. Insert the internet cable in the WAN port of the Modem.

  3. Connect the WAN side of the Home Router to a LAN port on the Modem.

  4. Connect the computer to a LAN port of the Home Router.

  5. Connect a LAN port of the Wireless Router with a LAN port of the Home Router.

  6. Configure the computer to receive DHCP.

  7. Configure the Home Router such that the DHCP server is enabled and it has an IP in the range. Make sure you set the range to something that will exclude both routers, eg. .0.2 - .0.254.

  8. Configure the Wireless Router such that the DHCP server is disabled and it has an IP in the same range as the Home Router, but not the exact same IP. For example, set your Home Router to end with .0.1 and your Wireless Router to end with .0.254.

    It might be necessary to temporarily connect your computer to the wireless router in order to perform these steps, if you forget the IP of the router just reset it first so you can connect to it.

    If your Wireless Router supports bridge mode; after setting the above settings, insert the cable that runs between both routers in the WAN side of the Wireless Router and enable bridge mode.

  9. Connect the Android to the Wireless network and make sure that your Android is set to DHCP.

As an end result, both the Computer and Android device will receive an IP from the Home Router.

It broke sometimes because the routers sending out two different ranges of IPs over the same network. Sometimes your Computer and Android Device get to be in the wrong range and are confused over how to route their data along, it's non-feasible to have your data first sent to the wrong router...

How do I make my wired computers inaccessible from wireless?

Note: This set-up puts your computer in a private network inaccessible from WiFi.

 INTERNET                   Schematic: The wired computers in a private network.
    |                                        
____|____
|       |
| MODEM |                                        
|_______|                     
    |                                        
 ___|WAN______                    
|             | DHCP SERVER ENABLED.
| WIRELESS R  | DHCP RANGE: .0.2 - .0.254
|_____________| OWN IP: .0.1     
    |LAN  :WIFI     
    |     :
    |   ANDROID
    |   DHCP ON.
    |                                  
 ___|WAN______               
|             | DHCP SERVER ENABLED. BRIDGE MODE DISABLED!
| HOME ROUTER | DHCP RANGE: .1.2 - .1.254 
|_____________| OWN IP: .1.1
    |LAN
    |   
 COMPUTER                               
 DHCP ON.                             

The following steps have to be performed:

  1. Disconnect everything.

  2. Insert the devices as shown in the schematic.

    Internet <--> WAN Modem LAN <--> WAN Wireless R LAN <--> WAN Home R LAN <--> Computer

  3. Configure your Computer and Android device to have DHCP on.

  4. Connect your computer temporarily to the Wireless Router.

  5. Reset the Wireless Router, give it IP .0.1, set it to give DHCP range .0.2 - .0.254.

    Make sure its Wireless settings are configured right, take the highest security and a good password.

  6. Connect your computer to the Wired Router.

  7. Reset the Wired Router, give it IP .1.1, set it to give DHCP range .1.2 - .1.254.

    If you have problems after you reset the router, temporarily plug out the WAN cable during configuration because that could be because both routers got assigned to the same range.

  8. Configure the Android device so that it connect to the Wireless Router.

Now wireless devices won't be able to access your computer anymore.

share|improve this answer
    
+1 for ascii drawing.. how do you even find the time... –  ppumkin Dec 14 '11 at 20:23
    
+1 for the ASCII. Damn how I miss the early 90's. –  trolle3000 Dec 15 '11 at 0:22
    
So both routers need static IPs, not only the WiFi one? Thank you. I will try that today. –  Eugene Dec 15 '11 at 8:21
    
@Eugene: After reading all your comments across the question, I have now suggested an alternative solution in my answer which is what you will want. The set-up as described in your question as well as in the various answers here won't give you extra security; to gain extra security you have to put your computer in a private network as opposed to the wireless router, that way the best they can access is the router but they can't do much to it unless you enabled remote configuration options or mis-configured the firewall... –  Tom Wijsman Dec 15 '11 at 14:29
    
@TomWijsman Okey. Thank you. So in the end for one routers should be connected in diff. order. First comes WiFi and then comes standart router. –  Eugene Dec 16 '11 at 9:12
show 2 more comments

If I understand right, your setup looks like this : modem - router 1 - WiFi router.

Which is the DHCP master here, and are you sure that there is only one ?
And to which modem/router is your PC connected, and is this via cable or WiFi ?

If, for example, the WiFi router is also a DHCP master, then it may create its own network on which there is no Internet available, for example 192.168.0.xxx, while the modem creates its own network of 192.168.1.xxx. Your PC may then randomly join the network of whichever router answers first its DHCP query.

You can check this using in a Command Prompt (cmd) the command ipconfig in both situations, where Internet is available or not, to see if your network (the first 3 numbers) changes.

share|improve this answer
    
Scheme is correct. PC is connected to router 1, not over WiFi since it is non-WiFi router. PC has IP 192.168.0.xxx and he receives it from router 1 and Android device after connection to WiFi router gets IP 192.168.1.xxx. So I have only one option, to set static IP on PC or it will not help and there is another way? –  Eugene Dec 8 '11 at 18:26
1  
Just turn off DHCP on the WiFi router, so it will join the existing network. –  harrymc Dec 8 '11 at 18:30
    
Well, now after turning off DHCP on WiFi router I can't even connect to the router itself via LAN. –  Eugene Dec 8 '11 at 18:53
    
Also, how can PC connect to some other router if he is already connect to one? –  Eugene Dec 8 '11 at 19:02
2  
@eugene: I think it is /possible/ you are misunderstanding what he means by "turn off dhcp" (he wasn't specific). You want to turn off DHCP SERVER on the wifi, letting the other one be the sole authority to hand out ip addreses. You will want to set the LAN IP of the wifi router to STATIC and with a number in the same range as the other router's DHCP server is set up to hand out (which sounds like 192.168.0.xxx). Chances are high that the other router is 192.168.0.1, so your wifi might be static 192.168.0.2. –  horatio Dec 14 '11 at 19:57
show 8 more comments

Most non-commercial home routers have very limited processing power and ram. So yes two routers on the same network can cause dropped connections, strange port and networking behaviors, and routing issues especially if routing protocols like RIP and BGP are turned on. You didn't mention what type of routers you have or if you have flashed them with any third party firmwares such as DD-WRT or Tomato USB or whatever. If you are looking for security looking at using one of those firmwares and segmenting your wireless traffic using the tools provided in them would be a more efficient method. (Less possibilities of things to go wrong)

share|improve this answer
    
Updated question. –  Eugene Dec 7 '11 at 17:20
    
I think your main issue is still running two routers behind each other. You can look at the IP ranges on both devices to verify that they do not intersect causing routing collisions. (ie both devices are giving out ips on the same subnet) I would point you again to one of the firmwares above to extend the capabilities and security of the wifi router. –  J Baron Dec 13 '11 at 20:38
add comment

What port on the WiFi router are you connecting to. A LAN port or it's WAN (Internet) port? If you are using one of its LAN ports then it is possible it is still running a DHCP server. If your PC got its network information from this DHCP server then it would get the wrong default gateway and you'd lose internet access.

If you are connecting to its WAN port then it shouldn't have any adverse affect on normal web browsing. The double NAT may make some things screw up but normal browsing should just be a tiny bit slower.

Also, what extra security are you hoping to get from using the two routers connected like this?

share|improve this answer
    
To the WiFi router I mostly connect via WAN with my Android device. Well as I understood, then such scheme is better due to that all PCs at home connect to non-WiFi router and WiFi router is connected to non-WiFi router, so it mostly doesn't interact with home PCs. –  Eugene Dec 8 '11 at 18:32
    
@Eugene: Unless you have a very good understanding of networks, and you know your way around, that's not possible to achieve. What you are currently doing is just creating an interference setup where both routers confuse all devices. It doesn't matter whether you connect them like you did before or like I describe, in both ways they will interfere. Do you want me to draw a scheme in my answer that explains you how they should be connected for that security? But I really suggest you to only have the Wireless Router, if you take the strongest security setting you'll be secure... –  Tom Wijsman Dec 15 '11 at 14:05
add comment

My Suggestion to you. For a better security follow this.

1. Use only one Router. I would suggest ASUS Wifi Router.
2. Set MAC Filtering On. Allow the MAC address of the machine that you know  
3. Disable the Wifi SSID broadcasting and,
4. SET the security to WPA2-PSK-TES.
5. Use 10-20 length password like AsusWL-530gV2!!!#

Its enough for your network and its security.

share|improve this answer
add comment

Internet connections are not magic. When you say your conneciton failes one of three thigns in happening

  1. You are losing the physical link between your computer and the Wi-Fi router
  2. You have link to the Wi-Fi router , but you don't have a connectio nto the Edge Router
  3. You have connection the The Wi-Fi router and the edge router but you cannot reach the external Gateway.

Each of these three devices have an IP address you can try to connect to to figure out where you are losing the link. Next time your internet connection goes down you need to do the following

  • Look at the connection lights on the back of your computer and the port on the wi-fi router you are plugged into
  • Attempt to ping the wi-fi router
  • Attempt to ping the edge router
  • Attempt to ping the Gateway

The place that you can't reach is where your connectivity is failing at. Using that information will help you further troubleshoot exactly what the problem is.

In a separate point altogether your set-up provides you no additional security and is rather obtuse. Drop the DLink router and just use the Wi-Fi router.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.