Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I shutdown the computer, I need to disconnect all USB devices(mouse, flash drives, USB hub) because their lights are bright and it's hard to sleep or I can just power off computer by PSU PWR button. My motherboard is Gigabyte GA-945PL-S3. Maybe there something in BIOS that I can change(because it's very annoying)?

share|improve this question
    
possible duplicate of Gigabyte motherboard (890gpa-ud3h) won't shutdown USB power –  techie007 Dec 6 '11 at 19:16
    
Does the power supply have a power switch (not the PC's switch)? –  Aki Dec 6 '11 at 19:20
    
@Aki Yes, this is the second option. But it's not so easy to get to computers back and turn off. All USB devices are plugged to single USB hub so I just disconnect the hub from PC. –  Little Helper Dec 6 '11 at 19:27
    
Your motherboard manual....encrypted.google.com/… –  Moab Dec 6 '11 at 20:21
add comment

1 Answer

Your motherboard presumably keeps standby power on them (probably it supports "Wake on USB" functionality). There may be a BIOS option, as I'm not familiar with this exact board, but such an option is exceedingly rare on non-laptops (EDIT: by which I mean, even if you disable Wake on USB, the board will still power the devices).

As a workaround to unplugging your devices, you could simply flip the master switch on the power supply to the 'off' position. (Anything that has an external power source may stay lit of its own accord, though).

share|improve this answer
    
Easiest way IMO would be to have an easily accessible power strip which your PC is plugged into, and just flip that off after you shut down. I have one that sits on top of a computer of mine and it has a nice big button on the front. Certainly easier than reaching around and flipping the PSU switch every time! –  Garrett Dec 6 '11 at 19:27
    
@gman makes a great suggestion, yes. Basically just some way to kill the power going into it entirely - whatever is most convenient for you. –  Shinrai Dec 6 '11 at 20:20
    
+1: Check the Wake on mouse/keyboard device setting under BIOs. –  surfasb Dec 7 '11 at 1:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.