Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Snow Leopard when you closed Preview.app and open another document with it, the previous documents did not reopen. On Lion, however, it seems that Preview is always reopening things that I thought I closed. How can I disable this behavior?

share|improve this question
add comment

4 Answers

up vote 3 down vote accepted

You can also use a utility called RestoreMeNot for disabling window restoration for individual applications.

enter image description here

It's a System Preference Pane that allows you to exclude apps from Mac OS X 10.7 Lion's Application Resume feature.

share|improve this answer
    
looks very promising. thank you –  cwd Dec 8 '11 at 20:24
    
It's just a UI to defaults write NSQuitAlwaysKeepsWindows, but nevertheless quite useful. –  Daniel Beck Dec 8 '11 at 20:31
add comment

Resume can be disabled from System Preferences:


You can also override that setting for individual apps with something like:

defaults write com.apple.Preview NSQuitAlwaysKeepsWindows -bool false

Most apps now have an action called Quit and Close All Windows or Quit and Keep Windows under ⌥⌘Q depending on the default set in System Preferences.


You can also prevent windows from being reopened by holding shift while opening an application. (It works when the application is opened from the Dock, Launchpad, or Finder, but not when using the Spotlight menu or some third party apps or scripts). And it doesn't work the other way around when Resume is disabled either.

share|improve this answer
    
Have you figured out how to enable it again from defaults? It ignored the value for me (only checks if set), and defaults delete does not work. –  Daniel Beck Dec 9 '11 at 12:14
add comment

Or, you can use cmd+option+q to quit the Preview.app. The next time opening the Preview.app, won't restore the window. The same method can be used for other application (e.g, Safari)

share|improve this answer
add comment

You can uncheck the "Restore windows when quitting and re-opening apps" checkbox in System Preference -> General.

It will not reopen things any more.

But after this setting, the preview no longer keep the last position of reading. Seems no perfect way to fix this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.