Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Often, when I mount a filesystem via ssh:

sshfs user@remote: ~/Mounts/Remote

and the machine hibernates (closing the Laptop lid) if I wake up the machine I can't access the mounted folder. Furthermore, if I try to ls in the parent folder, the terminal freeze. The same also happens when the connection is somehow lost.

If try to unmount using

fusermount -u ~/Mounts/Remote

I can't do this because:

fusermount: failed to unmount /home/yotama9/Mounts/Remote: Device or resource busy

I tried to kill ssh but I can't mount the folder again. ls in the folder still freezes.

How can I avoid this and fix this (Arch Linux)?

share|improve this question
up vote 9 down vote accepted

I suffer the same problem in Ubuntu Linux. What I do after resume:

$ killall -9 sshfs

Then, umount

$ fusermount -u ~/far_projects

and mount again the remote filesystem.

$ sshfs -o idmap=user youruser@server:/projects ~/far_projects
share|improve this answer
    
Thanks. I replaced killall with killall -9 – Yotam Dec 21 '11 at 12:40
    
I suggest making a script for more than one or two shares. It makes life a lot easier. – Alex Hirzel Jan 4 '12 at 3:40

I've had the same issue on my laptop.

All you need is to include the lazy unmount option (z) in your unmount command:

$ fusermount -uz ~/Mounts/Remote

Then just remount the same way you normally would.

Also, it's worth noting that I use the reconnect option (-o reconnect) which will maintain the connection through any hiccups (like closing your lid and coming back a few minutes later).

You can also look into a solution like afuse which is an auto-mounter for fuse filesystems (sshfs included) to save you the hassle of unmounting/remounting every time.

One final auto-mount option is using autofs with sshfs.

share|improve this answer

As noted here, this is your solution:

 -o reconnect,ServerAliveInterval=15,ServerAliveCountMax=3

As an example usage: https://github.com/ceremcem/aktos-dcs-tools Look at make mount-root target.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .