Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to start using iozone to benchmark a usb stick I have.

I want a very simple test to measure 4k random writes.
I tried following the manual to use relevant parameters, but I keep getting a weird error on most runs. Some runs will pass ok, though with extraordinary values such as 200000kb/s.

Most runs will simply fail as such

sudo iozone -i 2 -R -l 1 -u 1 -r 4k -s 10m -F ~/f3  | tee -a /tmp/iozone_results.txt

...
Min process = 1 
Max process = 1 
Throughput test with 1 process
Each process writes a 10240 Kbyte file in 4 Kbyte records

~/f3: No such file or directory

Can anyone please provide some advice on what am I doing wrong? I obviously have permissions, and just in case chmod 777 to my home dir and the relevant file system mount point.

share|improve this question

migrated from serverfault.com Dec 7 '11 at 15:01

This question came from our site for system and network administrators.

1 Answer 1

The iozone manual states that if you're going to use the -i argument, you need to include -i 0 in order to have files to test against. In your case, use -i 0 -i 2 to get your write test. If you don't specify that test, the other tests have no file to work with and you'll get the error you see.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.