Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

In Windows Explorer, when I click on the drive that happens to be my cd/dvd drive, I get the message "please insert a disk into drive", which might be OK, but then the DVD drive opens and I have to close it. I consider this very rude and I do not like it. Is there a way I can keep the DVD drive from opening when it is empty and Windows tries to access it?

share|improve this question
    
This is a charming question. :) I know of a few ways to stop this behavior, however they each involve disabling one built-in feature or another. If you do not use the built-in Windows disc burning feature, then I have an answer. –  iglvzx Dec 7 '11 at 17:45
1  
No, I don't use Windows for disc burning, and I would also like to get rid of that stupid desktop.ini that is always waiting to be burned (in Windows Explorer). –  xpda Dec 7 '11 at 17:57
add comment

marked as duplicate by raven, Tog, tapped-out, techie007, Dave M Nov 18 '13 at 18:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 5 down vote accepted

You can effectively stop the 'rude' auto eject behavior by disabling the built-in CD burning settings.

Quick Solution:

  • Set the following value in the Registry:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoCDBurning"=dword:00000001

Solution:

  • Open the Local Group Policy Editor (gpedit.msc).

    Run

  • Navigate to User Configuration\Administrative Templates\Windows Components\Windows Explorer.

  • Find and double click the Remove CD Burning features setting.

    Settings

  • Change the setting to Enabled, and click Okay.

    Enabled

  • Log off and then log back in.


Before:

  • Context menu (notice the Burn to disc option).

    Burn to disc

  • When we double click the drive, this message pops up and the disc tray pops open. >:(

    Insert disc

After:

  • CD Burning has been disabled. (The Format... option is gone, too...)

    CD burning disabled

  • When we double click the drive, the disc tray does not eject! :D (I don't know why they changed the spelling of 'disc'...)

    Insert disk

share|improve this answer
1  
Perfect! Thanks! (There's no group policy editor on my system, so I used the reg file here: sevenforums.com/tutorials/…) –  xpda Dec 7 '11 at 19:30
    
Ah. Yes. The Group Policy Editor changes the same registry value. I will update my answer to include that method. It's strange that there is no setting for disabling just the auto eject behavior. –  iglvzx Dec 7 '11 at 19:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.