Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is an interesting conundrum where all the normal solutions don't work.

Yesterday, I downloaded several movie clips with a wmv and avi file extension when booted in Ubuntu after hibernating my Win7 installation. I use a NTFS-formatted partition to store common files for independent OS usage, and this is where the clips were downloaded. While the videos were downloading, I watched one via streaming the .part file extension to VLC. The video came through fine and I had no issues with it.

Today I tried to load up the second one, and I kept getting stream unresolved errors. After a look at the file sizes, I saw that one was 46KB and the second was 336KB, when the real sizes should bee 480MB and 1.2 GB, respectively. These files just won't delete.

Here's what I've tried so far

  • rm -f FILE.wmv
  • rm -i ./FILE.wmv
  • mv FILE.wmv File2.wmv

In all cases, I've had the error cannot remove file: no such file or directory found

However, a ls -l check shows that the files DO exist and the appropriate read/write permissions are set.

Any solutions come to mind?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

If Windows has access to an NTFS partition (ie it is mounted), and is hibernated, it will assume that the partition is unaltered when it comes out of hibernation - it will carry on where it left off. Same with linux in the other direction.

So if you boot linux after hibernating windows, alter the contents of the partition, and then resume Windows, this will almost certainly lead to corrupt files.

While you can fix this with ntfsfix on linux, or chkdsk on Windows, you will end up losing data.

share|improve this answer

Try checking your NTFS partition.

You can use ntfsfix (part of the ntfs-3g suite).

share|improve this answer

Did you try a sudo rm? I have had strange permission based issues when accessing a non-ext4 partition on my own system (I quad-boot Win7, WinXP, Ubuntu Studio, and Linux Mint), and in quite a few cases running a rm, mv or cp command with sudo allowed me to fix the issue.

And before anyone down votes for relevance let me say I only mention this because I have gotten the "file not found" error when interacting with a perfectly healthy Windows partition in Linux.

Hope that helps...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.