Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having some trouble connecting to an Ubuntu 10.10 server.

I am using Fedora 16.

Some things that I have tried

  • The server and all of its shares can be seen on the windows computer.

  • I can ping the server and other window machines successfully

  • I have installed samba and samba client on the fedora machine.

  • Under Network on the fedora machine, I have one option "Windows Network"

    *After installing Samba and samba client I was able to enter.

    *I then am given a Work Group Icon *When Trying to connect to the work group I get the error message

    Unable to mount location - Failed to retrieve share list from server

Additional Notes/Updates

-The windows machine on the network also has a shared folder (Which cannot be seen)

From the research I have done already it seems that the only way to solve this is pretty complicated. I have been through a few tutorials, guides, etc but nothing has fixed the issue.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I was finally able to connect.

Earlier I had tried mounting via terminal after modifying /etc/fstab and was still unable to get that to work.

Finally I added the following line to /etc/fstab

//SERVER/SHARE /home/name/folder cifs user=USER,uid=1000,gid=100,noperm 0 0

To have it auto mount the directory some parameters needed to be specified and your password needed to be stored somewhere.

//SERVER/SHARE /home/name/folder cifs users,auto,credentials=/path/credentials_file,noexec,noperm 0 0 

A file was then created with the directory = to credentials=/path/credentialsfile and these two lines were added to that file. Correct permissions etc were given by using the tutorial I link to later.

user=usernameofshare
password=sambapassword

Where:

SERVER = IP of Server
/home/name/folder = location to mount too
SHARE = the share name of the folder/file, not sure if using the real name when the sharename is different will work.
USER=my username

When I run mount -a the share mounts successfully.

This link has some nice examples of every type of connection

FSTAB Modifications

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.