Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Fujitsu Laptop, and it came with 4GB of RAM and an Integrated Intel Graphics adapter. As only 3Gb's shows up to the OS, I'd like to decrease the amount of shared Graphics Memory. I checked in the BIOS and graphics properties but can’t seem to find where to make the changes. If anyone has experienced the same I’d be interested to know. As I could never imagine an intergraded graphics adapter using anything above 256MB, even with a large external monitor attached!!

Here are the details: Laptop is a Fujitsu Lifebook S7220 Model FJNB1E7

Intel(R) Graphics Media Accelerator Driver for Mobile Report
Report Date:    	09/06/2009
Report Time[hr:mm:ss]:  10:42:53
Driver Version: 	6.14.10.4953
Operating System:   	Windows XP* Professional, Service Pack 3 (5.1.2600)
Default Language:   	German
DirectX* Version:   	9.0
Physical Memory:    	3025 MB
Minimum Graphics Memory:    32 MB
Maximum Graphics Memory:    1024 MB
Graphics Memory in Use: 10 MB
Processor:  	x86 family 6 Model 23 Stepping 10
Processor Speed:    	2666 MHZ
Vendor ID:  	8086
Device ID:  	2A42
Device Revision:    	07

*   Accelerator Information   *
Accelerator in Use: 	Mobile Intel(R) 4 Series Express Chipset Family
Video BIOS: 	1646.0
Current Graphics Mode:  1440 x 900 True Color (58 Hz)
share|improve this question
add comment

4 Answers

shared memory is dynamically adjusted depending on the requirements.

and if you're wondering why you only see 3~ GB RAM, read this: Dude, Where's My 4 Gigabytes of RAM?

share|improve this answer
    
+1 Your shorter answers always seems better then mine :( –  Diago Sep 6 '09 at 11:19
    
IDK, but something seems to be wrong here, according to the Fujitsu spec sheet, the GMA 4500 MHD is using up to 384 MB of shared memory (Intel says up to 512 MB though), but not 1024 MB. which program did you run for the report? –  Molly7244 Sep 6 '09 at 11:49
    
I got the info from the tech suport tool in the Intel graphics tool in control pannel, it's correct, dxdiag shows the same 1024MB allocated for graphics ;) –  Darragh Sep 6 '09 at 13:18
add comment

First things first, is your machine 64 bit? That would limit you to ~3GB anyway.

Next, if you can go in to the BIOS, you can usually limit the maximum amount of memory that the Intel Graphics can take up - take a look.

share|improve this answer
    
I had already checked the BIOS and it gives no options related to graphics just to change the display ports (DVI, VGA, etc..) –  Darragh Sep 6 '09 at 13:20
add comment

This is fairly normal for notebook integrated cards actually. Even my older Acer with a dedicated NVidia card used to do this. This doesn't mean it is using 1GB thought.

Most notebooks although sporting 4GB of RAM, will rarely if ever give you full access to all of it, and normally will only give you access to 3.5GB. The rest of the memory is allocated as system resources, shared between the graphics card and other devices on your machine, as or when required.

In your case because your running 32-Bit Windows XP it can only see the first 3GB anyway, you will find upgrading to 64-Bit you will only be able to reference 3.5GB. I won't recommended 64-Bit Windows XP because drivers are a killer, but Windows 7 64-Bit would run like a dream.

Unless there is an updated BIOS that allows you to change this setting, there is no way to adjust it anywhere else.

share|improve this answer
add comment

I suspect this has more to do with the 4GB addressing limit related configurations
rather than graphics shared memory.

Besides the Codinghorror link already given by Molly,
there are Pushing the Limits of Windows posts by Mark Russinovich for further reading.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.