Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Seagate ST3500620AS (Barracuda 7200.11) hard disk:

  • SATA
  • 500GB
  • 7200 spindle speed

I've used this disk for about 2 years now. But today it happened that my computer wouldn't wake up from sleep state. I hard turned off my computer and after turning it back on, I couldn't load the system and after some time of waiting a message came up, that OS can't be loaded from the network.

Checking my BIOS settings I can see that disk is not recognised by it. I unplugged it, put in another disk which got recognised just fine.

Then I tried connecting faulty disk to a different computer via USB (because I have a SATA-USB dock for a portable Seagate) but it didn't get recognised by the system either. I also run Disk management in case disk wasn't partitioned or anything so it would be recognised but not displayed in Explorer. No luck either. Disk doesn't show up anywhere...

So my conclusion is that this disk is now officially dead (RIP my working friend)... But I'd still like to recover more than valuable data from it. Bank certificate is just one of them...

How can I do anything to get to this disk's data? Is there any software that can actually bypass BIOS and access a device directly? Is that at all possible on an everyday machine? Should I start thinking of a data recovery service provider that would do it for me and recover valuable data?

Additional notes

  1. Disk physically isn't completely dead because on power-up it spins-up, heads get positioned (by the sound of it).
  2. Network related boot is most likely initiated by computer BIOS, because boot priority is
    HD > Floppy > Network...
share|improve this question
@Robert: Was your drive manufactured in December 2008 or earlier? – Mark Johnson Dec 8 '11 at 18:42
@MarkJohnson: As per Date code it was manufactured on October 24th 2008. – Robert Koritnik Dec 8 '11 at 19:00
@Robert: Almost certainly the firmware bug then. – Mark Johnson Dec 8 '11 at 20:13
up vote 6 down vote accepted

Sounds like you've been bitten by the BSY bug (the drive event log location has been set to an invalid location by an off by one error in the firmware). This contains a reference to your model being affected. At one time, you could send the drive into Seagate and they'd revive it by updating the firmware, you'd end up paying only for shipping. Hopefully they're still doing that. If not, you can do it yourself (another link). If you've got more of theses drives, get the firmware updated while they're still operational.


Here are some additional links. This one seems to be a good general introduction that discusses the cabling / voltage requirements for communicating with the drive. This one has more details / discussion.

share|improve this answer
Unfortunately I only have one single drive... No FW update possible I suppose. I was already checking eBay for a similar PCB... :( – Robert Koritnik Dec 8 '11 at 19:01
The Serial cable trick seems easy and straight forward. The only problem is that the other machine is a notebook. No serial connector there... Can it be done somehow using USB (based on the cable on screen in forum post seems it's possible)? – Robert Koritnik Dec 8 '11 at 19:09
@Robert: Try contacting Seagate, they may still take care of this for you for the cost of shipping. A USB/serial adapter should work, looks like you're just issuing commands to the drive, nothing that should be extremely timing sensitive. – Mark Johnson Dec 8 '11 at 20:11
Seems rather simple yes as long as I can find a machine with serial port that is of course. :) And thanks for these links. I've contacted Seagate and will see what they suggest. – Robert Koritnik Dec 8 '11 at 20:49
Nice find! I like user-hack fixes like these (on the other hand, I know how bad it feels when your life ends up on hold because of such a problem). In any case, if you use the cable method, note that even though it says User Partition Format…, it is not actually deleting your data. Whew! :-) – Synetech Dec 8 '11 at 21:32

If your device is not being recognized by the system, that might indicate a bad controller. That's good, because it means your data is likely still safe on the disks themselves. But it's also bad, because you'll need to use a data recovery firm that can replace the controller in a clean room environment. But at least there is a relatively high chance of their success.

share|improve this answer
If I attach a different hard disk on the same computer, BIOS recognises it without a problem. And data is 99.9% still safely on platters, because nothing physically happened to disk itself. It was in power down mode and died in the meantime (I know I don't believe these kind of things myself, but it surely seems to be this time). – Robert Koritnik Dec 8 '11 at 15:49
But if you're talking about the controller on HD itself than that could be it. Replacing PCB should suffice I suppose. BTW: Thanks for your encouragement... – Robert Koritnik Dec 8 '11 at 15:51
Yes, sorry, I meant the controller on the disk, not your SATA/IDE controller in your computer. That should be something relatively easy for a data recovery firm to complete. – Tim Dorr Dec 8 '11 at 15:58
@Tim: If replacing the logic board does not involve cracking the drive case, why would that require a clean room environment? – Mark Johnson Dec 8 '11 at 18:35
@MarkJohnson: You're right. PCB is easily accessible on the outside of disk housing. – Robert Koritnik Dec 8 '11 at 19:10

My Seagate external drive started failing two weeks ago. It got very warm, so I unplugged it and let it cool, and it would work fine again for a couple of days. Eventually I began to hear clicking and knew mechanical failure was near. I managed to archive what I needed most from it before it completely quit and refused to be recognized.

I'd heard about the freezer trick for years but never believed it. At this point I figured, what have I got to lose, so I put plastic kitchen wrap around the drive and let it sit in the freezer overnight. To my surprise, after a couple of minutes, the drive's folders began to show up one by one. I immediately began copying files to a fresh drive, which worked great for about 15 minutes, until the HD warmed up and quit again.

Seeing that temperature is a factor, and having heard that you can do this trick four or five times before it totally fails, I brought a portable refrigerator/freezer into my office so that the drive could sit in it and stay cold on my next attempt. Unfortunately, all I've gotten so far is an "install new software" prompt, but it doesn't see its software to install itself. Had I been able to keep it cool on my first attempt, I might have been able to recover everything, but I'll never know.

So the freezer trick worked for me, but not long at all. For the first time ever I'm considering a cloud backup service.

share|improve this answer
In my case it was the BSY bug (as per accepted answer) and I was able to fully recover from it. Disk still works flawlessly. – Robert Koritnik Aug 29 '12 at 9:39

This is worth trying before paying for recovery or opening up the drive. Something that has worked for me is to place the drive in a a Ziplock type bag and remove as much air as you can. Place the drive in a freezer for several hours. If possible, connect the drive to a known good system with a USB adapter or external case( put case in bag too) and see if you can read. This has worked a number of times for me.

Sometimes a longer stay in freezer has helped.

Others have found this works Freeze Drive A quick Google found may videos and other articles. IBM server training used to mention this as a fix to try.

share|improve this answer
What's the freezer treatment supposed to do that gets the drive working again? – Mark Johnson Dec 8 '11 at 18:30
Not sure why the downvote. This has worked for me and many others. The cold causes the metal to move/shrink. It may change where the head sits or the platter. It may free a bearing (maybe not an issue here) I recovered over 300GB of data from a drive that was dead. Have done this on a number of drives but it does not always work. But it is free and it can work. – Dave M Dec 8 '11 at 19:54
@MarkJohnson: Maybe if drive overheated it would help. Especially if it went dark because PCBs chips overheated a bit to malfunction. Just taking it off power for a few minutes should help just as well in such situation. – Robert Koritnik Dec 8 '11 at 19:55
The thing that seems key here is the movement of the metal parts, not teh cooling of an overheated part. Agree taht if circuit was overheated, normal cooling would address teh issue unless the circuit was broken. – Dave M Dec 8 '11 at 20:07
freezing has been known to work if there's a head/mechanism related issue, not firmware errors. – Journeyman Geek Dec 9 '11 at 7:33

If the drive spins, try booting to the A> prompt, run Fdisk and check to see if Fdisk can see a partition on the hard drive. If Fdisk can see the partition, that means that it can access the drive and that the controller electronics are functioning correctly. If there is no head clatter, it may be just a matter of disk corruption which commonly occurs when a surge hits you machine and overwhelms the power supply voltage regulator. It commonly over whelms the system electronics allowing an EM pulse to wipe out the master boot record, file allocations table, and primary directory. Fdisk can fix the master boot record and Norton Disk Doctor can restore the FAT and Directory from the secondaries.

share|improve this answer
Instead of doing what you suggested I've tried a similar thing by running Disk Manager to see if drive is visible, but offers no physical partition. The drive wasn't there, since even BIOS doesn't recognise it. It has all the symptoms of a BSY error described by @MarkJohnson. I'll try to get the Nokia data cable to fix it... And then update firmware immediately after! – Robert Koritnik Dec 9 '11 at 8:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.