Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use emacs to edit files encrypted with gnu privacy guard. Im using the gpg support built into emacs 23 which I think is easy pg assistant. I import keys created at the command line with M-x epa-import-keys. When I save a file with suffix .gpg I first get to choose recipients among the keys installed on my computer. I choose one of them, my own key created by myself. I then get the question: Use untrusted key anyway? (y or n). What does this mean and how can I disable it? gpg works fine from the command line.

Versions: gpg (GnuPG) 1.4.9, emacs 23.3.

share|improve this question
up vote 5 down vote accepted

Works fine now, here's what I did:

  1. On the command line: I used gpg --edit-key, and then changed the trust level of my key to the highest level.
  2. In Emacs: I changed the epg-gpg-home-directory variable to the .gnupg directory holding my gpg key.
share|improve this answer

You need to use any of "sign" options with edit-key

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .