Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This seemed to happen out of the blue. I have been using Opera for years.

I can't find anywhere in Gmail to change the default font that is used in Opera.

Ubuntu is Version 11
Opera is version 11.6

In Firefox the font is normal size.

I have tried playing around with both all the browser setting I can find plus Ubuntu system settings (I had seen some mentions of Opera using the system default font sometimes) but no success so far.

Really bumming as I have been using Opera for two years and if I can't resolve it I will not be able to use it.

I can switch to Firefox but I don't want to.

share|improve this question

migrated from stackoverflow.com Dec 8 '11 at 17:49

This question came from our site for professional and enthusiast programmers.

    
OK, I'm flagging again as off-topic. I understand that it is technically within SU's broad scope, but I think that it will get more attention from Ubuntu experts at askubuntu.com. And @studiohack, you can feel free to delete any of my comments on this thread, as it is too long and too meta. –  Eric Wilson Dec 8 '11 at 18:39
    
@EricWilson this question is on-topic for SU, and we only migrate to SE sites with overlaping scope if the OP specifically asks us to. Otherwise, the question stays, as the last time the OP indicated his preference, it was on Stack Overflow. –  studiohack Dec 8 '11 at 18:51
    
Just showed up on my mac so not just Ubuntu ! –  Michael Durrant Jul 9 '12 at 2:15

3 Answers 3

up vote 3 down vote accepted

It looks like it's a bug in Opera 11.6+: http://my.opera.com/community/forums/topic.dml?id=1157352&t=1323469056&page=1#comment10836852

I'm zooming the web page when writing emails now (and zooming out when done). Works quite nice (and you get the editor ~fullscreen :)

[Note from michael: Accepted this as it "answers" the question, but also see workaround below!]

share|improve this answer

This comment provides a style-sheet fix:

  1. Create a file containing this: .LW-avf {font-size: small !important;}

  2. Save this file as gmail.user.css into the Opera folder /usr/share/opera/styles/

  3. Log in to your Gmail account. RIGHT click on any empty space and select "Edit Site Preferences". Select the "Display" tab. Go to "My style sheet" textbox and browse for the gmail.user.css file.

Then reload the page.

share|improve this answer
    
Yes this fixed it! Hard to not to change my accept, so made my q about why but also gave this workaround fix an upcheck. –  Michael Durrant May 22 '12 at 14:27
    
Unfortunately the same fix doesn't work for Windows :( –  Michael Durrant May 26 '12 at 11:34
    
For a Mac I put the file in my home directory and then selected it via step 3. –  Michael Durrant Jul 9 '12 at 2:33

According to this Gmail support discussion the cause of this problem is that Opera used to have the font too large in gmail, for which Google created an Opera-specific fix.

In 11.60, Opera fixed their bug, but Google has yet to remove their fix, so that the now too small text returns back to its normal size.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.