Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today my mother has complained about issues with the internet connection on her laptop: a few days ago, GMail worked, but today it and all other sites won't load, resulting in a "time out error". The laptop connects to old D-Link G604T router via Wi-Fi and the router is often malfunctioning, so I've rebooted it. No effect.

Next, I've tried to open the router's web configuration panel and it loaded fine.

After that, I tried to load the OpenDNS site with IP address (208.69.38.160), and it worked well too.

Next, I've tried to ping gmail.com from the cmd.exe and saw a strange thing: ping tried to send packages to 1.0.0.0. It was the same thing for all other domains, too! I've checked the hosts file, but no - it was clear.

Now, I'm stuck, because I have totally no idea what should I check/try next. Any ideas?

EDIT:

C:\Documents and Settings\Евгения>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 13 02 71 e5 22 ...... Intel(R) PRO/Wireless 3945ABG Network Connection
 - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active routes:
Network Destination        Netmask          Gateway       Interface   Metric
          0.0.0.0          0.0.0.0      192.168.1.1     192.168.1.6       25
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0      192.168.1.6     192.168.1.6       25
      192.168.1.6  255.255.255.255        127.0.0.1       127.0.0.1       25
    192.168.1.255  255.255.255.255      192.168.1.6     192.168.1.6       25
        224.0.0.0        240.0.0.0      192.168.1.6     192.168.1.6       25
  255.255.255.255  255.255.255.255      192.168.1.6     192.168.1.6       1
Default Gateway:       192.168.1.1
===========================================================================
Persistent Routes:
  None
share|improve this question
    
Can you bypass the router and connect directly to the internet? –  Shinrai Dec 8 '11 at 20:22
    
From the cmd prompt, type "route print" and see if you see any routes defined as 1.0.0.0 –  shufler Dec 8 '11 at 20:23
    
@shufler added, but I can't see anything interesting :-/ –  Oleg Kuznetsov Dec 8 '11 at 20:51
    
@Shinrai no and other machines in the network are working fine –  Oleg Kuznetsov Dec 8 '11 at 20:53
    
Betting it has something to do with a captive portal. Our Cisco WAP redirects all HTTP requests to 1.1.1.2 until the user has signed in to the WAP. –  ultrasawblade Jun 21 '12 at 12:52
show 1 more comment

3 Answers

up vote 0 down vote accepted

It sounds like something changed some of the settings. Let’s hope it was a piece of legitimate software that was installed and not some malware. Either way, there are a few steps you can use to find and fix it (reboot after each one).

  1. Get Autoruns and run it. In Options, select Verify and both Hide options. Now check the Winsock tab to see if there is anything suspicious. If so, disable it and reboot. If that fixes it, you can delete it. (You can also use Autoruns to check for other things.)

  2. Try the command netsh winsock reset catalog (XP SP2+).

  3. Try the Microsoft FixIt tool for this problem.

  4. Try WinSockFix[1][2]. This is my go-to tool for Internet connection problems.

  5. And finally, a couple more advanced-troubleshooting guides from Microsoft

  6. If worse comes to worse, you can try uninstalling the network adapter in Device Manager, then rescanning to reinstall it from scratch.

  7. Optionally, run a malware scanner or two if you suspect she got infected by something.

share|improve this answer
    
Thank you very much! Step #4 helped! –  Oleg Kuznetsov Dec 9 '11 at 9:30
    
No problem. WinSockFix is my #1 choice for connection problems. –  Synetech Dec 10 '11 at 22:15
add comment

This may actually be a router problem. I see a lot of chatter regarding DNS returning 1.0.0.0 and Linux machines, some suggestions to disable ipv6, and then googling around based upon your router model, I also see some firmware fixes such as v1.00b05 "DNS Pass Through with DNS relay fix"

See: ( http://www.google.com/search?q=1.0.0.0+D-Link+G604T )

share|improve this answer
add comment

What is your dns settings? Do they point to the router or do they go to your ISP dns servers? This sounds like your computer is getting a bad dns response.

share|improve this answer
    
Obtain automatically -> so it grabs settings from the router –  Oleg Kuznetsov Dec 8 '11 at 20:56
    
@Oleg - try entering 8.8.8.8 manually for the dns server. –  Joel Coehoorn Dec 8 '11 at 23:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.