Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Latitude D620 laptop. It was free. When I got it, it worked fine for three days. Then, whenever I turn it on, the screen is a garble of blue lines and shakiness. I hooked the computer up to an external monitor and it displays perfectly. So the LCD is bad, right?

I disconnected the LCD from the D620 and installed it on a Latitude 120L. The 120 uses identical connectors on a different style of ribbon. On the 120L, the same garbled blue lined LCD displayed crystal clear.

So, I have replaced the inverter chip/board, I have replaced the LCD ribbon cable, and I have pulled out most of my hair. This laptop has the notorious nVidia chip, but supposedly, if an external monitor is okay, the chip shouldn't be bad.

Can anyone offer me a suggestion on how to proceed?

share|improve this question
    
Have you tried reinstalling the Dell drivers for the display? Maybe they have become corrupt. –  CharlieRB Dec 8 '11 at 20:33
add comment

3 Answers

same thing happened to me. I connected to an external monitor and also saw the same lines. However, when I moved the mouse, it started to "clear" the lines and I could see the a prompt for system restore. I clicked on this - let it do its thing and guess what - it WORKED! From all the past views of on line forums and reading post with similar problems, I was getting ready to tell the owner they needed a new motherboard! SO try this - it may work for you!

share|improve this answer
add comment

Here is what I would look at:

  1. The RAM itself. RAM diagnostics are great but not necessarily that accurate so if you have spare RAM that would be a good test. Do the diagnostics on the existing RAM as well anyway.

  2. Make sure if you have them, to run the Dell full diagnostics. If that adapter has its own memory, I've seen the video RAM go bad in such a way as to cause some very odd errors that only manifested under "just right" conditions and many of them had the very same video corruption you describe.

  3. Refresh any and all video drivers to the newest. If that don't work, try an older version and see how that rolls.

If none of these work I'd wonder when you swapped that LCD over to another system, did you use the cable from the D620 or totally detach it and use the cable that was with the other system? If you used the existing cable from the D620, I would try and swap that out as well and inspect the cable terminus on the motherboard to ensure it's intact/undamaged.

share|improve this answer
    
FYI... sorry I think I should read more before the cable stuff lol. My bad. –  OG Chuck Low Dec 8 '11 at 21:40
    
Thanks for the excellent edit Gareth! –  OG Chuck Low Dec 10 '11 at 21:58
add comment

I would put money on the connector itself, or just the circuitry of the internal output itself being bad. I Have repaired a bunch of 620's in the past and I have seen this problem before where external looks fine, but internally the video is terrible. Always had to replace the video card. My money is on the video card.

share|improve this answer
    
Well, I stripped down the motherboard and took my wife's "salon quality" hair dryer and blasted the nVidia chip from about half an inch away at full heat and power. After I let things cool for 15 minutes, I hooked up the and keyboard to the motherboard, plugged in the adapter, crossed my fingers and voila' video is beautiful. So, looks like the chip is bad and since 620s have the integrated chip, I guess I'll be trolling eBay for a reasonably priced used motherboard, preferably with an Intel video chip. So, a good display on an external monitor doesn't seem to guarantee the chip is okay. –  Shannon Dec 9 '11 at 0:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.