Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set my share to full control on computer A, but when I access the share from computer B, it prompts me for password.

Also, when I type in the password in the password dialog box, it works fine, until computer B restarts, and I need to type the password again.

I have to keep setting the scheduled tasks for copying a file from computer A to computer B everday.

share|improve this question
    
What version of Windows? You may need simple file sharing enabled. –  Tog Dec 9 '11 at 7:58
    
XP( computer A) and Server 2003 (computer B). I am using batch files to copy files, so simple file sharing is not an issue here. –  nearownkira Dec 9 '11 at 9:38
    
Fair enough, but it looks like you are experiencing exactly the same issue I had between a Win 2000 and multiple XP PCs –  Tog Dec 9 '11 at 19:38
add comment

1 Answer

I set my share to full control on computer A, but when I access the share from computer B, it prompt for password.

The first thing done when connecting to a SMB server is authentication – the client always has to provide credentials, whether automatically by OS or entered manually by you. How much control you give to the share is irrelevant, and is only checked when you start copying files.

When I type in the password in the password dialog box, it works fine, until computer B restart, and I need to type the password again.

Check the "☑ Remember my password" box in that dialog.

share|improve this answer
    
even if there share option is EVERYONE -FULL CONTROL , security option also EVERYONE -FULL CONTROL. all these while, I thought it was the reason why I put full control for everyone, so user no need the server administrative credential. so what i now should do is go to each pc and add the server credential in the control panel -User account -crdential manager? –  nearownkira Dec 9 '11 at 9:41
    
According to your comment above 'computer B' is your server and it forgets the password when rebooted. How regularly do you reboot your server? –  HaydnWVN Dec 9 '11 at 10:14
    
@nearownkira: Authentication as a user is always required regardless of what ACLs are set, simply because it is impossible to check ACLs without knowing the user. (Besides, 'ANONYMOUS' doesn't even belong to 'Everyone' anymore.) The only way to make it optional is by enabling the "Guest" account in User Accounts, and even that has some rules. –  grawity Dec 10 '11 at 21:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.