Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I remember that in the old version of Firefox I could type "google maps" in the address-bar and Firefox would navigate to http://maps.google.com/.

Since I upgraded to Firefox 8 I can't do this anymore. I must type "googlemaps" instead — no space between "google" and "maps".

Is there a way to make sure that Firefox returns to the old behavior, which I like better?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Googling google maps from address bar brings me search result page in Firefox 8. However, you can try resetting tool-bars, search engines and preference to default:

enter image description here

share|improve this answer
    
It works! After reset all user preferences to Firefox defaults and installed Browse By Name addon : addons.mozilla.org/en-US/firefox/addon/browse-by-name I now get exactly what I want. Thank you. –  ITFan Dec 11 '11 at 8:53
1  
@ITFan Resetting the preferences has dothing to do with it. You should write about an addon in a separate answer instead of accepting this one. –  kinokijuf Jan 14 '12 at 19:11
add comment

What's happening is that google at the start of what you type in the adress bar is now considered as a special keyword indicating that Firefox should "google" whatever comes next. One way to get around it is to start with a different word. So

maps google

will work, as would

google google maps.

I don't know of a way to disable the new behaviour, however (nothing I found in Preferences or at about:config seems to deal with it)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.