Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Vostro 3450 laptop connected via HDMI to an external monitor. Windows 7 is configured to use only this external monitor, disabling and turning off the laptop screen.

This setup works when I cold boot Windows 7, but when I resume the laptop from hibernation, the external monitor is deactivated and the laptop screen is turned on.

The laptop has a Intel graphics adapter and a ATI Radeon dedicated adapter. Both drivers are updated.

Does anyone knows how to solve this? Thanks!

share|improve this question

2 Answers 2

Um... I am not sure if you are going to like this solution but... I am assuming if you the lil' guy hooked up to an external monitor that you also have him plugged in yes? So... you could just tell it via control panel power management to Never Sleep when plugged in.

Alternatively, you could maybe double check your chipset drivers, maybe even go so far as flashing your BIOS. I think before I'd even go near flashing the BIOS you might try entering the setup and start disabling some of the power management features there but... if you do, I suggest keeping a handy list of which one(s) you are trying so you can put stuff back in the event of negative results.

share|improve this answer

I might have discovered a workaround. Being with an ATI graphics card myself, I've got ATI CCC installed. I ran it ( one way of doing this is to right click on your desktop and select "Graphics properties" ) and when under the "Desktops & Displays" menu, there's a "Detect Displays" button that seems to have fixed the issue for me. Windows has a similiar button in the "Screen resolution" setting that, sadly, doesn't work. Not really sure what the cause is, but this procedure seems to have worked. Hope it works for you as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.