Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Wireless Cards Not Being Recognized by networking

I have two separate Wireless network adapters that I have tested against this Windows 7 home-built PC. Neither are working: after inserting the USB device, using device manager to add the correct (latest) Win 7 x64 drivers and installing the drivers successfully, Windows is still posting "problems" with the USB wireless devices. Troubleshooter is saying there may be a problem with the driver. I have reinstalled Windows, tried the devices in any of the 10 USB ports on my computer and have had no success. Proprietary connection software that comes with the devices fail to recognize the devices, though in Device Manager, they appear correctly, no exclamation mark or anything.

Networking was fine until graphics card failure

I've had this P55-Sli based PC working for over a year, with one of the network adapters in question. Worked great, ran a little hot. I left it running for about a week for a really long download and when I came back to it, the graphics card was fried. Computer wouldn't post. Replaced the graphics card and bought a new wireless card since the other one was a little flaky (I often had to unplug it and plug it back in after a reboot so the computer would recognize it).

Driver installation hangs until device is unplugged

After installing the new graphics card with no problems, I attempted to install the new wireless adapter (a D-Link DWA125 Rev A2). Strange thing was that every time I have tried to install the driver for this device, the process completely stalls... until I unplug the device and then it finishes up. In other words the progress bar advances to a point and then just doesn't advance, even for an hour, until the instant I unplug the device and then it instantly finishes up.

Windows reports error with driver software

Note that this is not the case the with other adapter - the Netgear WGT111. That adapter installs just fine, and, like the D-Link, after installation, I can see it in the Device Manager, correctly identified, no exclamation marks. It's just that Windows just doesn't do anything with it and when I try to use the Windows 7 troubleshooter all it reports is "there appears to be a problem with the driver for this device." I get the same message from the troubleshooter with the D-Link device as well.

Wireless Device Installs Fine on other PC

Just tried installing the D-Link device on another Windows 7 x64 PC and it was a flawless install. Didn't hang at the detection stage, and the DLink wireless detection wizard detected the device and proceeded to connect to the WLAN. So it's almost certainly something else on the PC in question itself.

Tethering no longer works

I also used to tether my Android phone all the time via a USB connection. Now, when I plug in my Android phone and turn on tethering, absolutely nothing happens.

Next Steps?

What should my next troubleshooting steps be? How can I run a diagnostic on my USB controllers to ensure they're delivering enough power? Could the new graphics card (which is different from the previous one) be causing any kind of conflicts? Is there anything I should be checking in BIOS?

share|improve this question
    
Is it just the wireless adapters? Have you tried other USB devices, (e.g. flash drive) to isolate the issue to just the adapters? –  iglvzx Dec 11 '11 at 23:06
    
Also, have you tried installing the adapters on another Windows 7 PC? –  iglvzx Dec 11 '11 at 23:13
    
I'm currently running a Logitech wireless mouse and keyboard via USB (a single "unifying" USB dongle). They seem to be operating great, though I once suspected there might be a conflict. Does USB have "IRQs"? –  Tom Auger Dec 12 '11 at 1:25
    
I haven't tried the adapters on another PC. I will give that a shot tomorrow. –  Tom Auger Dec 12 '11 at 1:25
1  
As per my edit, adapter works great on another PC with a similar architecture and OS –  Tom Auger Dec 12 '11 at 14:47

1 Answer 1

up vote 1 down vote accepted

So this has been resolved and there were two factors at play: 1. the EVGA P55 SLi Mobo needed a BIOS firmware update to 0407E 2. Plugging a USB 1.0 device into the mobo interrupts any USB 2.0 wifi activity. No idea why, it just is.

Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.