Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried using my 2 GB microSD card using the built-in card reader. On clicking the drive I get:

Please insert a disk into SD/MMC

The card works fine on other computers, as does the microSD-to-SD attachment.

I have tried the following to fix:

  • Updated Windows Vista and installed SP1.
  • Updated the TI drivers for FlashDrive.
  • Checked the VAIO site for updates (none required).
  • Added a new entry as advised here:

    HKLM\SYSTEM\ControlS* et001\Services\tifm21\Parameters/SDParam=1

I have restarted the PC multiple times. As soon as I put the card in, the SD/MMC device icon blips, so it seems the hardware is at least detecting something. The card reader was working fine a few days back.

I guess a Windows update has broken something. How do I proceed?

My laptop is a Sony VAIO VGN-N365E.

share|improve this question
If you're running 32bit vista, just apply the updated driver you'll find on the Sony site, if you're running 64bit Windows it seems for now - no drivers are available for that card reader. – JL. Sep 29 '09 at 6:59

Update Hey naunidh, Have you tried downloading the "Original - Memory Card Reader/Writer Driver Registry Patch" under "Memory Card Reader/Writer - 3 file(s)" from the Sony eSupport website? this should reset any changes made by pesky updates.

Edit: A quick question naunidh you say

The card reader was working fine few days back

Was that with the same memory card or a different one?

End Edit

Micro SD cards are not supported by your laptop according to the Specs of the VGN-N365E on the Cnet review;

Supported flash memory cards: Memory Stick , SD Memory Card , Memory Stick Pro , Memory Stick PRO Duo

Use a Micro SD to SD adaptor.

share|improve this answer
The OP is using one as per his post. – BinaryMisfit Sep 6 '09 at 19:50

As far as I remember HKLM\SYSTEM\ControlSet001\Services\ is only a backup. Does it help fixing the same key in CurrentControlSet?

Maybe there's just something wrong with the drive letter assignment. Go to the management console (right-click "My Computer", choose "Manage") and go to the disk/volume manager. Find if one of the volumes has no drive letter assigned or try to set it to another drive letter. Then restart.

In the management console you also find your installed hardware in the hardware manager. Try to remove the driver for the card reader and restart. Have a look if all drivers are in working state (no red or yellow exclamation marks).


You said the problem exists since you applied a Windows update. Try reversing your registry changes (you can first export the key to a regfile so you could reapply them later easily). Then in the next step open Start > Run > "sfc /scannow". This will scan your system libraries and restore them to a sane state. You'll need your Windows install CD (or at least the i386 directory from which Windows was installed).

share|improve this answer
I do not have a volume manager, Disk management shows all the drives with SD/MMC drive showing as "No Media". – naunidh Sep 8 '09 at 15:04
Sorry I corrected the wording. At least it looks like Windows really detects no volume in the drive. So I'd next go for hunting driver problems. – hurikhan77 Sep 9 '09 at 0:40
I am installing some 7 new updates that have come in today, I will then try what you say and get back. – naunidh Sep 9 '09 at 15:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.