Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running VirtualBox 4.1.6 on Windows 7 on fairly quick machine with 12G of ram. I have a virtual machine running Ubuntu 11 on which I am doing rails development using ruby 1.9.3 and rails 3. When I run up the WebBrick server and try to browse to the site from the host OS (Windows 7), there is a long delay before the page is returned, and it’s the same for subsequent requests. Accessing the server inside the virtual machine is quick. I am running in bridged mode but have tried a few other options it doesn't seem to help.

I can ping from the host the guest OS without any perceptible delay. I also tried connecting to an Apache server running on the guest from the host add it connects quickly. Tried running Apache on a nonstandard port (8080) and its still fast so don't think its port specific. Have tried starting WebBrick using -b to bind to both 0.0.0.0 and the actual IP address bound to eth0. Looking at theWebBrick console, the delay seems to happen before WebBrick sees the request.

It looks like the problem is specific to WebBrick but I am at a bit of loss to explain it as I am not a network guru. Are there any diagnostics I can try?

share|improve this question

migrated from serverfault.com Dec 12 '11 at 14:07

This question came from our site for professional system and network administrators.

    
Are you using the IP address to access webrick server on your browser, or hostname? There may be a problem with the DNS setup if you are using hostname. –  Can Kavaklıoğlu Dec 11 '11 at 10:41
    
I am using the IP address. –  Shane Dec 11 '11 at 10:46

1 Answer 1

up vote 0 down vote accepted

I fixed this by setting: DoNotReverseLookup to true in the WebBrick config file. See this link..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.