Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Windows 7 machines, both with Windows Update set to "ask me before downloading or installing." Occasionally (about twice in two months so far), the machines seem to reboot themselves when I'm not around. This happened both times overnight. (Both are on a corporate network.)

What I would like to do is somehow determine the reason, and/or time of the reboot. For example, I can see that Windows Update did not install anything since November, so I know that it can't be that.

Any ideas?

share|improve this question
1  
You sure this isn't a coperate policy? The fact its only happen twice tells me these restarts are from the patch tuesday that happens, once a month. –  Ramhound Dec 12 '11 at 14:28
2  
Look into the system event log. –  ZippyV Dec 12 '11 at 15:04
    
@Ramhound I'm quite sure it's not a corporate policy. Nobody else in the office experienced reboots at this time. –  ashes999 Dec 12 '11 at 15:17
    
@ZippyV what am I looking for? No reboots or errors reported; I have continuity of event logging across both days. –  ashes999 Dec 12 '11 at 15:21
2  
There should be obvious entries surrounding the reboots (at least of services starting afterwards). Check what the last few entries before the shutdown were, unless you have a hardware malfunction there should be clues to what initiated the shutdown. Either way, there usually is a message about a core dump somewhere. –  Eroen Dec 12 '11 at 16:05

2 Answers 2

up vote 2 down vote accepted

Reboot and other activity may be logged in the Windows Event Viewer under "Windows Logs" also check Custom Views > Administrative events for serious issues.

share|improve this answer
    
It does mention an unexpected shutdown/reboot -- no cause given. –  ashes999 Dec 12 '11 at 20:50
    
It looks like a power outage due to a faulty UPS unit. Sigh. –  ashes999 Dec 21 '11 at 16:59

It could also be Windows restarting itself after a hardware error.

Check Control Panel -> System and Security -> Action Center, and then under "Check for solutions to unreported problems," click on "View problems to report." You might see some entries there.

Now, under Control Panel -> System and Security -> System, look on the left hand side and check "Advanced system settings." Under "Avanced" go to "Startup and Recovery." Click "Settings," and make sure that under "System Failure," the option "Automatically restart" is unchecked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.