Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several rules which mark items as read and then send them to a specific folder. Nearly all of these folders are nested within one parent folder.

The issue is that usually when I get one of these messages, Outlook will expand the parent folder. I have no need for this sort of notification. The entire point of me automatically marking messages as read is that I don't need to know about them.

Can I stop Outlook from auto-expanding folders when they get new mail? I get dozens of these messages a day, and it's frustrating to constantly close this folder only to have it reopen minutes later.

I'm using Outlook 2010.

share|improve this question
    
Do you find that this happens if you are using "Folder List" instead of "Mail" for that pane? –  Ƭᴇcʜιᴇ007 Dec 12 '11 at 16:31
    
Just tried it under "Folder List" and it appears to still be happening. –  Kris Harper Dec 12 '11 at 16:32

4 Answers 4

I have also had this annoying issue with Outlook. I like some of the solutions above, but I am not an admin on my work computer, so I have resorted to moving those folders which I need Client-Only Rules to move emails to (which are marked as read) back out to the top level under Inbox. I use punctuation as a prefix to sort these folders (you could use numbers as well) so that I can send the unimportant ones to the bottom of the list. ie !Meetings #Projects $Service Tickets etc.

If the "subfolder" is no longer nested nothing expands. I know this is not a great solution, just a work-around.

share|improve this answer
up vote 0 down vote accepted

I have found that the folders only expand when I have my rules set to mark items as read. If the rules simply move the items to folders, but leave them unread, the folders don't expand. I suspect this is because marking them as read makes the rule a "client-only rule" which means it only runs when the client is open.

I find this to be a particularly annoying aspect of Outlook and Exchange. Because I got tired of constantly collapsing my folders, I decided to turn off the mark-as-read parts of my rules. And because I want all my read, I wrote a program which communicates with Exchange and recursively marks all items as read. I set this program to run every minute using Task Scheduler.

If you would like to use the same program, you can find the source code here. You will need Visual Studio to compile it. You will also need to download and install the Exchange Web Services API from here.

Incidentally, this also solves the problem I had in this question where Outlook would constantly tell me I had unread mail when I didn't.

share|improve this answer

I finally made my Outlook folder stop opening every time I get a new email!

I went to RULES > MANAGE RULES.

I found the rule that was affecting that email, and for that rule, I unchecked the option called "ON THIS COMPUTER ONLY".

A few minutes later, I checked, and sure enough - I had received emails in the folder. It stopped opening automatically.

share|improve this answer
    
Would you be able to provide a screenshot for each step of the process you went through? –  xxx Jun 11 '13 at 20:52
    
None of my rules had this box checked. This solution does not work for me. –  Kris Harper Jun 12 '13 at 13:04

Too sad, but you cannot change this behaviour. The only way do disable folder auto-expansion is to use server-side rules. These rules are available when using Outlook + Exchange Server. Unfortunately, the limited subset of conditions and actions is available in server-side rules.

share|improve this answer
    
Why would it be server side? This seems like purely a client issue. Am I missing something? –  Kris Harper Dec 13 '11 at 19:04
    
This is a client issue. This is why server-side rules do the trick: Exchange Server manages all the actions leaving Outlook unaware. –  thims Dec 14 '11 at 6:09
    
I'm a little confused. I'm not certain that my rules are server or client side, but: A) I can create a rule (such as "permanently delete mail from a certain person") and when I save it, I get a popup that says it's client-side rule and and will only run with Outlook is open, B) I have other rules that don't give me that popup (so I assume they are server-side), but C) those rules (in B) still cause the folder auto-expansion to happen. Does that make sense? How can I specify a rule to be server-side vs. client-side? –  Jer Oct 10 '12 at 20:21
    
Ok, I figured out one problem - many of my rules had "stop processing more rules" which I guess makes it a client-side rule. I removed that so they're all server-side now. But they are still making the folders expand - are you sure about your answer? –  Jer Oct 10 '12 at 20:34
    
Completely sure. –  thims Oct 11 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.