Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows XP, you can have whole-pixel anti-aliasing by setting "Use the following method to smooth edges of screen fonts" to "Standard", or have sub-pixel anti-aliasing (for LCD monitors) by setting the option to "ClearType".

In Windows 7, I can no longer find a way to enable whole-pixel anti-aliasing, which gives the best readability on DLP projectors and CRT monitors (these screens do not follow the RGB or BGR pattern found in LCD screens). It is either ClearType or no anti-aliasing at all. I tried a 3rd party tool (ClearType Switch) but unchecking "Use ClearType" while leaving "Enable smooth edges for screen fonts" checked disables all forms of anti-aliasing.

How to turn off ClearType and use whole-pixel anti-aliasing in Windows 7?


Edit: According to Microsoft's blog article "Engineering Changes to ClearType in Windows 7", enabling "Smooth edges of screen fonts" in Performance Options and disabling ClearType with ClearType Tuner would give you grayscale font smoothing (i.e. what I want). However, this is simply not true. It disables all forms of anti-aliasing (or, in their terminology, it gives you bi-level rendering).

And to clarify, I'm talking about changing the system default setting, i.e. the one that would be used if the application do not specify its own.

share|improve this question
    
I wonder if Gabe's answer would help? After you turn off Cleartype. –  opsin Jan 26 '12 at 2:17
    
@opsin: it doesn't look relevant. Am I missing something? –  netvope Jan 26 '12 at 8:48
    
If you use the Adjust ClearType wizard while using the projector, the following screens after you turn off ClearTYpe might possibly let you visually select the sub-pixel anti-aliasing option. –  harrymc Jan 26 '12 at 9:17
    
@harrymc: In step "3 of 4", the right-most choice is whole-pixel anti-aliasing (i.e. what I want). However, if I turn on ClearType in the very beginning, Windows will continue to use sub-pixel anti-aliasing (disregarding my choice in the subsequent steps); and if I turn off ClearType in the very beginning, Windows will disable all forms of anti-aliasing. –  netvope Jan 26 '12 at 9:55
    
When I turn off ClearType in the wizard I can in step "3 of 4" click the right-most choice. Do you mean that this has no effect? –  harrymc Jan 26 '12 at 10:14

3 Answers 3

Computer, Properties, Advanced system settings link in left side pane, Advanced, Performance, Settings, Visual Effects, Untick Smooth edges of screen fonts, OK.

share|improve this answer
    
-1 This will turn off font smoothing altogether –  kinokijuf Apr 14 at 15:06

I have found a solution to this problem, and it is highly customizable. It's called MacType.

It allow you to change the font rendering of all programs that I tried, selectively or en masse.

It has a number of default profiles to choose from, or you can make your own with a wizard that allows you to fine-tune just about every aspect of the rendering, including of course the choice of grey scale rendering.

profiles

It even runs inside Sandboxie so you can try it without worry about what it might do to your system.

I've only been using it for ten minutes so I don't know how stable it is but for now I'm extremely happy to have found this.

share|improve this answer

To use whole-pixel antialiasing:

[HKEY_CURRENT_USER\Control Panel\Desktop]

"FontSmoothing"="2"
"FontSmoothingType"=dword:00000001

Note that most Windows fonts are specifically set not to smooth1 at normal (7-13) sizes (fareast fonts even disable cleartype at those sizes).


To disable antialiasing altogether:

[HKEY_CURRENT_USER\Control Panel\Desktop]

"FontSmoothing"="0"
"FontSmoothingType"=dword:00000000


To reenable clear type:

[HKEY_CURRENT_USER\Control Panel\Desktop]

"FontSmoothing"="2"
"FontSmoothingType"=dword:00000002

Registry settings taken from an XP machine.


1Above 9 PPEM, anti-aliasing is turned off until the main stems of the font are around two pixels wide, which is around 13 to 20 points, depending on the typeface. (…) Two pixel wide stems are usually chosen because there is usually enough “backbone” of foreground colored pixels to keep the stem contrast high. (…) So although font smoothing was the default, most fonts, when displaying text at typical reading sizes, would render them bi-level.

share|improve this answer
2  
Thanks for the inspiration. Now I see that the problem is in the fonts, not in the ClearType configuration. For many fonts (Arial, Courier New, Georgia, Tahoma, Times New Roman, Verdana), whole-pixel anti-aliasing is disabled at normal sizes, but it kicks in at 14+pt, which is kind of lame. In my opinion, anti-aliasing is much more important at smaller sizes. In contrast, new Windows Vista/7 fonts (Calibri, Cambria, Candara, Consolas, Segoe UI) can have whole-pixel anti-aliasing at normal sizes. Perhaps Microsoft make it this way to promote their new fonts. –  netvope Jan 28 '12 at 19:25
    
@netvope It’s probably for backward compatibility purposes. These fonts already existed before font smoothing was introduced in Win95, and there was not much space to both add antialiasing and retain existing font metrics. With cleartype, you get 3x horizontal space on the other hand. –  kinokijuf Jan 28 '12 at 19:28
    
I could be wrong, but I think whole-pixel anti-aliasing worked for these fonts back in XP, at normal sizes. If so, the question becomes whether it is possible to force whole-pixel anti-aliasing for the old fonts. If whole-pixel anti-aliasing relies on some hinting from the fonts, Microsoft might have removed them in the old fonts to make it technically impossible. –  netvope Jan 28 '12 at 19:28
    
No, it’s impossible. I’ve seen how MS fonts look on a mac, which ignores hinting, and they look horrible. –  kinokijuf Jan 28 '12 at 19:31
    
@netvope I am currently using XP and the fonts look the same (no antialiasing). In fact, I obtained those numbers by experimenting. –  kinokijuf Jan 28 '12 at 19:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.