Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a computer whose user (Administrator account) says he changed network sharing settings for C:\ but made a mistake and after that, C: was no longer accessible.

Windows generally starts, some programs such as explorer.exe and cmd.exe can be started, but others such as regedit.exe cannot. Also, many settings dialogs, control panel options etc. are not displayed because "Administrator has restricted access" or "Server cannot be started" or just no message. I can, however, access everything in the C:\Users\ directory (still, the dir command in cmd.exe fails even there). I seem to be able to start MMC and add snap-ins.

Drive C:\ is shown without drive name in Windows Explorer. I can open its properties, but can't change the owner of drive C:\ or indeed access any options there at all.

Safe mode and domain controller restore mode don't change any of this as well (which is why this advice didn't work either because of regedit and because I can't change the owner.

How can I restore access to drive C:\?

share|improve this question
2  
Sounds like he buggered up the file permissions while trying to set Share permissions, Have you tried a System Restore yet? –  Ƭᴇcʜιᴇ007 Dec 12 '11 at 18:20
1  
ICacls c: gives what? –  soandos Dec 12 '11 at 18:26
    
@soandos: c: NT-AUTORITÄT\SYSTEM:(OI)(CI)(F) <newline> VORDEFINIERT\Administratoren:(OI)(CI)(F) <newline> Arbeit-PC\Arbeit:(OI)(CI)(F) <newline> Arbeit-PC\HomeUsers:(RX) <newline> 1 Files successfully processed, at 0 files a processing error occurred. –  Felix Dombek Dec 12 '11 at 20:15

1 Answer 1

Not sure why they didn't put it into a full fledged answer but yes, the first place I would go on this would be an attempt at System Restore.

share|improve this answer
1  
Because 1/2 the 'answers' would be "Have you tried a System Restore yet?" :) –  Ƭᴇcʜιᴇ007 Dec 12 '11 at 19:36
    
It can't find any restore points, not sure if there are none but at some point the program also gave me an "Access denied". –  Felix Dombek Dec 12 '11 at 19:38
    
@techie007 LOL FAIR, WIN - chastised LOL! –  OG Chuck Low Dec 13 '11 at 3:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.