Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two notebooks, one white and another that is red.

I want to connect them through their local adapters and share the internet connection of the red one that is received through WiFi. I could do the opposite, and share the white computer's internet connection through the cable.

I tried the following schemes:

  • white WiFi adapter disabled, red WiFi enabled and shared. And with both local adapters configurations on automatic;(which is recommended and taught by many tutorials online)

  • Same as before with static IP and the red one as the gateway of the white and the WiFi adapter of the red as gateway of the red PC;

I've tried several other combinations as I became hopeless to make it work, but I think those represent well the main possibilities.

As requested, the details, they are set to automatic, nothing interesting on the IP setting page, but here there is the fact they aren't in the same IP range(yes, I have the cross-cable and the direct one):

share|improve this question
    
Have you got the two notebooks communicating with each other over the wire? –  Ƭᴇcʜιᴇ007 Dec 12 '11 at 19:30
    
Yes. It is because the White computer WiFi adapter is failing, then it needs another source of internet. –  Juliano Dec 12 '11 at 19:44
1  
Can you take snapshots of the TCP/IP Settings of both local adapters? It sounds like they may be configured incorrectly. Set them both to automatic with sharing disabled. Enable the WiFi Sharing and the local adapters should automatically be reconfigured with static/dhcp addresses to communicate with each other. Another possibility is that Red notebooks will only work with Green notebooks. White ones are not compatible. Invest in spray paint. –  kobaltz Dec 12 '11 at 20:02
    
Do you have access to the router which is providing the red notebook with Internet? –  CharlieRB Dec 12 '11 at 20:48
    
Done what kobaltz suggested , didn't work. I'm no expert but I know how to do this. The problem is: it isn't working. The opposite sharing works, but when I need the red to share its internet, it doesn't works. Yes, I can access and manage it through wireless. I'm planning on moving it to a more accessible location. –  Juliano Dec 12 '11 at 20:50

1 Answer 1

The IPv4 APIPA addresses (auto assigned 169.254.x.x addresses) are not supposed to be routable, and MS started obeying this in Vista.

Try using another set of hard-set, routable IP addresses (like in the 192.168.1.x range for example).

Also depending on your setup, you may need to specify IPv4 gateways on the computers.

share|improve this answer
    
i like the 10.0.0.x range of addresses. Never used in home gear, and easy to remember. –  Journeyman Geek Dec 13 '11 at 3:02
    
I don't know how to configure static IP internet sharing. Those settings are automatic. Would you please exemplify that to me? –  Juliano Dec 13 '11 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.