Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a wireless local network where an XP Toshiba laptop cannot connect to the Internet, even though it had been working fine earlier in the day. Several other Mac machines connect without problems (though I've turned them off to make sure there's no IP interference issues).

The message I get in Chrome is:

Error 105 (net::ERR_NAME_NOT_RESOLVED)

The server at www.google.com can't be found, because the DNS lookup failed.

The thing I can't understand is that when I check my wireless connections, it shows status connected with strong signal strength. However, I can't ping anything, whether it is www.google.com or a Google IP address. If it was a DNS issue, wouldn't I be able to ping IP addresses?

Is this a DNS issue or not? Either way, what practical steps can I take?

Here is the ipconfig /all:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Kessler_Toshiba
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
k Connection
   Physical Address. . . . . . . . . : 00-13-02-D2-52-5A
   Dhcp Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IP Address. . . . . . . . . . . . : 192.168.1.103
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   Lease Obtained. . . . . . . . . . : Monday, December 12, 2001 8:57:09 PM

   Lease Expires . . . . . . . . . . : Monday, December 19, 2001 8:57:09 PM
share|improve this question
1  
Please edit and post an ipconfig /all from a command prompt –  Paul Dec 13 '11 at 2:29
1  
If you cannot ping IP addresses, it is not a DNS issue. It means, however, that your computer cannot reach the DNS server (hence the confusing error message). –  Dennis Dec 13 '11 at 2:35
    
Once you post the ipconfig I am going to ask you to ping the IP addresses of the default gateway and the DNS servers, so if you can figure out those, go ahead and ping them. –  Paul Dec 13 '11 at 2:44
    
Paul- posted the ipconfig- gonna need help w the second part... –  Yarin Dec 13 '11 at 3:10
    
@Yarin FYI, a 'strong signal' is not indicative of Internet access. It simply means that the connection between your computer and the access point (e.g. router) is good. –  iglvzx Dec 13 '11 at 6:33

3 Answers 3

up vote 2 down vote accepted

As nicatron and others mentioned, the issue was that the computer wasn't finding the default gateway. Here is the step-by-step solution that fixed this:

1) Determine the default gateway IP: I did this by using a computer that was already connected to the internet via the router- in this case a Mac, where I ran a netstat -nr command in terminal. (See also Instructions for finding default gateway for Mac and Windows)

2) Assign a static IP address: In XP, I went to Control Panel -> Network Connections -> Wireless Network Connection -> (Right-click) Properties -> General (Tab) -> select Internet Protocol (TCP/IP) -> click Properties... (See How to Assign a Static IP Address in XP, Vista, or Windows 7)

enter image description here

In the general tab, switch from Obtain an IP address automatically to Use the following IP address:

enter image description here

In this window, fill in the following:

  • IP address = (The IP address that you see when you run ipconfig from the cmd prompt)
  • Subnet mask = (The Subnet mask that you see when you run ipconfig from the cmd prompt)
  • Default gateway = (The Default Gateway you got in Step 1)
  • Preferred DNS server = 8.8.8.8 (This is Google's public DNS server)
  • Alternate DNS server = 8.8.8.4

That's it! Thanks to everybody for your help.

share|improve this answer

It appears that your DHCP server didn't provide a gateway address. Without a gateway you can't get out of your local network. For most home networks this is usually your router's LAN-side IP address.

Try an ipconfig /release and then an ipconfig /renew to refresh your settings via DHCP.

share|improve this answer
    
thanks- the issue with the gateway address is correct, however release/renew did not help in this case. –  Yarin Dec 13 '11 at 14:01

You don't have a gateway set for your network, which may be the cause if you're behind a router or a firewall. To test this, right click the network adapter, hit properties, and and enter your gateway, usually 192.168.1.1, or something similar. You might change the gateway to your DHCP server and see if that helps too. Although this should usually be given dynamically, assuming that IP currently is leased to you, you can just change everything to static and it should work the same way.

Example output from my Windows 7 box:

Ethernet adapter Tunngle:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Wireless Network Connection 4:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Wireless Network Connection 3:

   Connection-specific DNS Suffix  . : 
   IPv6 Address. . . . . . . . . . . : 2001:470:1f0f:983:d030:c78:972f:f7c6
   Temporary IPv6 Address. . . . . . : 2001:470:1f0f:983:889b:1d47:9bbf:9fe5
   Link-local IPv6 Address . . . . . : fe80::d030:c78:972f:f7c6%14
   IPv4 Address. . . . . . . . . . . : 192.168.0.150
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::226:5aff:fefc:e5e8%14

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
share|improve this answer
    
@nicatron- thanks, this got me started... I've posted the detailed solution for XP in my answer. –  Yarin Dec 13 '11 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.