Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a location named "Café en Madrid". If I try to set it with scselect on Terminal, the accented é is turned into gibberish and the command fails:

[kodai.fernando ~/Desktop] scselect "Café en Madrid"
Set "Café en Madrid" not available.

Defined sets include: (* == current set)
   64E7FFFD-4F08-46AB-ADAF-0CF5BEC57169 (Café en Madrid)
 * E790486F-5BDE-44D7-8C1D-43940F1F551C (Sao Francisco)
   D98A096B-5D3E-4FA2-8F72-915EE50FEC5E (Automatic)

How can I fix this? No I don't want to remove the accented char.

share|improve this question
1  
try to use scselect 64E7FFFD-4F08-46AB-ADAF-0CF5BEC57169 –  kamae Dec 13 '11 at 13:27
    
@kamae It's a good suggestion, consider posting it as an answer. –  Daniel Beck Dec 14 '11 at 17:14

1 Answer 1

scselect assumes its arguments is encoded as Mac OS Roman (search for kCFStringEncodingMacRoman), and Terminal is by default using Unicode (UTF-8). Change it in the preferences:

enter image description here


$ scselect "Café en Madrid"
CurrentSet updated to C88601E1-7163-429A-BB0C-E304DB2E00F7 (Café en Madrid)

Funnily enough, this breaks the output.


Consider reporting a bug to Apple.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.