Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Macbook Pro
13-inch, Early 2011
Processor 2.3 GHz Intel Core i5
Memory 4 GB 1333 MHz DDR3
Software Mac OS X Lion 10.7.2
Netgear WRT54G2; Hardware Model V1; firmware: 1.0.01 Cablevision internet

It's not the internet--Xbox works fine on the connection (albeit wired).


-Changed channel on router (it's at 11)
-tried to upgrade router firmware (doesn't work, downloaded and tried twice--the upload to the router times out after 10 minutes and nothing happens)
-reset router to default, and set up again

Console shows nothing remarkable outside of a consistent awacsd error around the time the wifi drops.

12/13/11 7:30:30.000 AM kernel: IOSurface: buffer allocation size is zero
12/13/11 7:32:24.030 AM awacsd: Starting awacsd connectivity-47 (Jul  7 2011 20:52:38)
12/13/11 7:32:24.045 AM awacsd: Connecting AWACS client:
12/13/11 7:32:25.208 AM Firewall: awacsd is listening from ::ffff: proto=6  
12/13/11 7:35:53.963 AM applepushserviced: <APSCourier: 0x700000005530>: Stream error occurred for <APSTCPStream: 0x000000005530>: The operation couldn’t be completed. Connection reset by peer

The only way to get the connection back is to turn off wi-fi then turn it back on.

I've been searching for a solution for several weeks now, but I've run out of things to try.

Where could I start tracing this error? What else can I do to try and track it down or fix it?

share|improve this question

migrated from Dec 13 '11 at 14:31

This question came from our site for system and network administrators.

I'm guessing this MBP isn't a server. – ceejayoz Dec 13 '11 at 12:48
OS Version would be helpful information. There was quite the issue with this in early Lion releases from what I recall. How does the ethernet port work? That have issues as well? – Tim Dec 13 '11 at 13:57
@ceejayoz no, not a server. edit: although there are things like MAMP on there and I think the built-in Apache might be running, but I'm not actively using either to server anything outside of local dev on the machine. – stormdrain Dec 13 '11 at 14:06
@Tim Software Mac OS X Lion 10.7.2 – stormdrain Dec 13 '11 at 14:07
@Tim also, I understand there have been many issues with earlier releases of the OS; my googling turned up a lot of people complaining about it (that's where I got the info to try and change the channel, etc.) None of the solutions I came across worked. – stormdrain Dec 13 '11 at 14:13
up vote 0 down vote accepted

Your main question is the following: Where could I start tracing this error? What else can I do to try and track it down or fix it?

Basically, your problem can be pinpointed to one of four sources:

  1. Your operating system and software
  2. Your Macbook hardware
  3. Wireless interference
  4. Your access point

You should first try to test your connection with another laptop. You could for example try with your smartphone or the smartphone of a friend.

If the problem persists, you know it is either due to wireless interference or your access point. Let us suppose the problem does not persist; the problem is due to either your macbook hardware or the operating system.

You should download an Ubuntu boot disk for your laptop model and try to use the WiFi network. If the problem persists in the same way, it is a software problem. Let us suppose it is.

Now, you have identified it is a software problem. You should now isolate on which level the problem is present.

  1. Does your laptop still report the WiFi card as being connected? Do statistics on received packets still change? If not, you could reconfigure your AP with no encryption; maybe this problem is WPA-related?
  2. If the statistics on received/transmitted packets still change, can you still ping the address of your access point? If so, this may be a router configuration problem.

Let us suppose the problem is your WiFi card / connection. MacOS is a UNIX-based system, so you should have some logs present in /var/log/ or dmesg, which you can access using a Terminal. See if there are any helpful errors present there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .