Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just moved from Ubuntu 8.04LTS to 9.04 (Jaunty); and for some reason the traditional window controls (that were present in 8.04) -min, max, close- are no longer present. Logging out and back in hasn't -as you'd expect- helped at all. I was wondering if you guys have any experience of bringing back the controls, or know why they've gone away?

If SF isn't the right forum -I have a suspicion it might be more SU- feel free to vote to migrate, or let me know and, if I can, I'll do that.


Edited: since I've just discovered that instead of being where they used to be, they're over on the far left, displacing the program icon from the left-corner to more...indented position.. Though the only control showing is maximize.

A sample title bar is in the linked picture, this one from Firefox -if it's relevant- and is slightly edited so that both ends of the title bar fit in the same image without it being of a ridiculous size.

A snippet of my screenshot demonstrating the Gnome problem


Edited: to answer jholloway7's question:

...Do you have Compiz enabled? If so, what's it look like w/o Compiz?

So far I've been unable to activate even 'Normal' graphics (the message received is: "Desktop effects could not be enabled"); so I'm assuming that the required graphics card is of a higher spec in Jaunty than Hardy?


Edited: for some reason -entirely- unknown to me, Gnome's suddenly decided to start drawing the windows properly. So the controls are now in their proper place, as is the program icon. I don't know why, or what happened. I'll vote to close the question now (I've not opted to delete, just in case anyone might feel better that if it happens, it also passes by). Thank you for reading, and I'm sorry to have bothered you all...

I'm also beginning to wish I'd never upgraded in the first place...sigh

share|improve this question

migrated from serverfault.com Sep 6 '09 at 20:02

This question came from our site for professional system and network administrators.

    
Do you have Compiz enabled? If so, what's it look like w/o Compiz? –  Joe Holloway Sep 6 '09 at 16:48
    
It is possible the gconf settings for metacity (The window decorator) got messed up somehow. The order is listed in /apps/metacity/general/button_layout –  Alvin Row Sep 7 '09 at 3:22
add comment

1 Answer 1

up vote 1 down vote accepted

Did you reboot or logout and login again, or restart gdm? It seems a few gnome libs were probably upgraded and they were referencing now out-of-install libs which were causing errors.

share|improve this answer
    
I restarted, downloaded packages, logged in and out...a number of times in various orders prior to originally posting on Serverfault. I...have no idea what happened, but your theory regarding upgraded libs/packages seems likely. Thanks =) –  David Thomas Sep 6 '09 at 20:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.