Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've downloaded a number of different drivers from the Dell's support page (i have a valid service tag), but I cannot get the Fingerprinter reader to work in my environment.

I am able to see the Control Vault w/Fingerprint Swipe Sensor driver listed under:

Control Panel > Hardware and Sound > Biometric Devices

When I click on Use your fingerprint with Windows, I get the following exception:

C:Program Files\Broadcom Corporation\Broadcom USH Host Components\BrcmFMA.exe

The application has failed to start because its side-by-side configuration is incorrect...

This error points to the Windows Application event log and this message:

Activation context generation failed for "C:\Program Files\Broadcom Corporation\Broadcom USH Host Components\BrcmFMA.exe". Dependent Assembly Microsoft.VC90.MFC,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.

I have yet to locate anything via Google. I am running Windows 7 64-bit.

share|improve this question
This might sound dumb... but are you sure you actually have the fingerprint reader? I get these all the time and that is not a default option the way we get them (yours could certainly be different). Either way make sure you also double check your Device Manager to ensure you have no problem components and if you do go get the drivers from the Dell support site. – OG Chuck Low Dec 13 '11 at 23:25
Yes, I've used it before. :) I re-installed the OS after a VMWare Workstation uninstall jacked up the networking config on the machine so bad I decided it was not worth troubleshooting and time for a re-build. – codewise Dec 13 '11 at 23:41
This might be another dumb one... did you go back and remove then freshly install any of the drivers that could be in question that auto recognized and got installed by the OS? Just a thought... in particular the Chipset Drivers and the Control Vault stuff. – OG Chuck Low Dec 13 '11 at 23:49
Well, in this last round of reinstalling I turned off Windows Update completely. I started by installing the Intel Network driver, downloaded directly from Dell. I installed all the software and drivers from Dell directly. I have a case open with Dell. I just want to know what I must install to get the fingerprint reader working. I admit, I have not installed everything labeled "Control Vault." I did install the item labeled something like "Control Vault Security drivers." – codewise Dec 14 '11 at 6:55
@codewise Were you able to resolve this issue? I have a similar problem when clicking on "Use your fingerprint with Windows". Same OS, same Latitude model, but different error. I am getting the following: "Windows cannot find 'C:\Program Files\Broadcom Corporation\Broadcom USH Host Components\BrcmFMA.exe'. Make sure you typed the name correctly, and then try again." – Pieter van Niekerk Jul 23 '12 at 9:02

I had the same problem and this is what I did.

Firstly I downloaded this driver and followed the Installation Instructions.

I was then stuck with the same problem you had. After some searching I found this.

I installed the 2008 SP1 Redistributable Package and it worked like a charm.

share|improve this answer
Just a note to say that this fix also worked for me Dell Lattitude E7440 fingerprint driver – Chris Buckett Jun 18 '14 at 4:34
I have Latitude E5450, installing the C++ Redistributable package did help. Thanks! – Lamorak Apr 16 '15 at 13:20
Installing the 2008 SP1 Visual C++ Redistributable (x64) package is the right answer. – Sven Nov 19 '15 at 13:00

I experienced the same problem you did on my Dell Precision 6700. I'm currently running Windows 8 Pro 64bit. I loaded the 2008 Visual C+ SP1 redistro package, enabled the fingerprint swipe, and didn't even have to reboot. I upgrade from Win7, so I could run a Virtual Machine of some OSs. Some people choose to download the 25 meg install file. I chose to download all of the system drivers. That download is 300megs and extracts to a gig and a half. It appears that the drivers are not dependent on the model.

share|improve this answer

You must log in to answer this question.

protected by bwDraco Mar 23 '15 at 20:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .