Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu 11.10 on VMWare Player. The OS is running well.
I already installed ruby 1.9.2 and rails 3 too.

When I shutdown the VMWare player and turn on again, my installed ruby is lost. I don't know what makes it lost. Any help please?

share|improve this question

migrated from stackoverflow.com Dec 13 '11 at 23:10

This question came from our site for professional and enthusiast programmers.

    
Are you certain that VMWare player allows you to make persistent changes? –  sarnold Dec 13 '11 at 7:08
    
i am a newbie on this area. i don't know either if vmware player doesn't have persistent change. how do i check it? –  mamatozay Dec 13 '11 at 7:20
    
Were any changes that you made to the system retained? Or were they all thrown away? Does the properties for your virtual machine (or block device?) allow writing to the virtual machine or block device? Do you have permissions to modify the files that hold all the virtual machine data? –  sarnold Dec 13 '11 at 8:09

1 Answer 1

check out your configuration. All configurations are set in the *.vmx file Open yourVirualmachine.vmx with notepad and check the snapshot.action entry. If it's set to snapshot.action = "autoRevert" no changes will be saved. Then change to snapshot.action = "keep" this will solve your problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.