Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed dnsmasq so I could use wildcard lookups for *.local addresses using these instructions.

The only difference was that mine was setup to resolved .local instead of .dev, like so:

address=/.local/127.0.0.1

It was working great when directly connected to a modem, but when connecting through, say, a public WiFi it was unable to resolve anything!

$ dnsmasq

dnsmasq: failed to create listening socket for 192.168.1.129: Permission denied

As an interim solution I removed dnsmasq:

$ sudo port uninstall dnsmasq

And then in my network preferences, I ran Diagnostics which detected a "problem" with my DNS settings. I clicked the button to revert those changes and the WiFi began to work again.

How can I re-install dnsmasq and set it up to avoid that WiFi problem? (E.g. a DNS setting I need to have or something with dnsmasq that I need to configure.)

share|improve this question

migrated from serverfault.com Dec 14 '11 at 3:02

This question came from our site for professional system and network administrators.

add comment

1 Answer

up vote 2 down vote accepted

.local conflicts with the domain used by zero-config solutions including bonjour. Choose a different domain.

If you are getting an IP address in the range 192.168.0.0/16 the domain on that network is likley .local. You may also get an address in the range 192.168.0.0/16 if you are unable to contact a DHCP server to get an address.

EDIT: localnet is a traditional alternative to local for your localnetwork. It is referenced on the dnsmasq FAQ.

share|improve this answer
    
So, that must be why a lot of places were saying ".dev" was better that ".local" huh? –  mmmshuddup Dec 14 '11 at 5:44
    
Yes, local is not an assigned domain name, but it as been co-opted. –  BillThor Dec 14 '11 at 5:58
    
Ok, well I've reinstalled dnsmasq and set it to dev this time. I'll let you know if it didn't work. Thanks! –  mmmshuddup Dec 14 '11 at 6:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.