Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a really big problem with upload speed on my desktop.

I have an ADSL connection in my flat, and I have added wireless router to make easier access for my laptop. My desktop computer was connected with a cable to that wireless router and he was the one which have started causing problems. When I wanted to connect to my Gmail or Yahoo page to log in, it wouldn't open them. Any operation which requires some upload from my desktop computer wouldn't be done.

I wanted to make sure, so I made a speed test, and downloads were determined without problem, but the upload test wouldn't even start. Then I attached the same cable to my laptop and did the speedtest and everything went fine. So, I thought that my integrated LAN card was the one making problems. I bought a wireless card and installed it and the problem was still the same! Download OK, but upload couldn't be determined.

Before that, I have tried switching off the firewall, reinstalled my browsers several times, have reset the options in BIOS to default, etc., without any progress.

The only thing that I noticed was that it was possible to log in to Gmail from gtalk nothing else. Even with this question, I was forced to send it from my laptop.

share|improve this question
    
Have you run a complete virus and malware/spyware scan yet? If not, do so. You need to make sure the system is clean before trying to troubleshoot this type of problem. –  CharlieRB Dec 14 '11 at 14:25
add comment

1 Answer

You have to understand that almost every connection you make with a remote server requires some "upload". As long as you can open any webpage or even see your network being recognized as connected means the "upload" side of your connection is working.

Your problem seems to be very limited upload bandwidth / high packet drop rate or some kind of filtering against upload traffic. Can you check if there's any anti-P2P or traffic management software installed on any of the computers on the network? (It doesn't have to be on your computer to affect you.)

Also, your MTU could be configured incorrectly on your desktop which becomes problematic if your router/ISP filters out ICMP packets necessary for the automatic MTU discovery. Follow this guide to fix it.

share|improve this answer
    
Answer in Command Prompt after first step: "The following command was not found: interface ipv4 show subinterfaces." –  Nikola Dec 14 '11 at 15:16
    
You have to run the command netsh first to enter a netsh prompt instead the normal command prompt. –  billc.cn Dec 14 '11 at 15:29
    
Maybe it wasn`t possible because of Windows XP? Still the same ... –  Nikola Dec 14 '11 at 15:59
    
Sorry that command is not available under Windows XP. Follow this guide and set the MTU value under HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces key/folder to 14xx. Also try setting EnablePMTUDiscovery="1" to enable MTU discovery. –  billc.cn Dec 14 '11 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.