Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With Excel 2007 I was able to use Open With to associate TSV files with Excel, so that I could double-click on them and they would automatically open with each value in a different cell. But since upgrading to Excel 2010, I can't select Excel as the program to use to open TSV files. If I use Open With and browse to the Excel.EXE and click Open, Excel still isn't in the list of programs to choose. If I select Excelcnv.EXE, then Excel shows up in the list, but I still can't open the file by double-clicking.

The best I've been able to do so far is open Excel first, then use it to open the TSV file, and then I have to do Text to Columns to break up the values. But I really want to have Excel launch just by double-clicking the file.

share|improve this question
    
Can you rename it to a .CSV? –  Ƭᴇcʜιᴇ007 Dec 14 '11 at 14:43
    
@techie I could, but that's a pain to do on a regular basis, and it also doesn't format it correctly on opening (since it is delimited by tab, not commas). –  bwarner Dec 14 '11 at 14:54
    
I was hoping a) it would be easy to rename them (low amount of them) and b) that it would auto-convert. Guess not on both accounts. :) –  Ƭᴇcʜιᴇ007 Dec 14 '11 at 15:01

4 Answers 4

up vote 11 down vote accepted

Found the problem while digging around in my registry.

HKEY_CLASSES_ROOT\Applications\EXCEL.EXE\shell\open\command 

was still pointing at the location of Excel 2007. Apparently the upgrade didn't update this?

Changing this to point at the location of Excel 2010 made it so that Excel would show up in the Open With dialog after I browsed to the EXE, so I could associate the file type and now it correctly opens and auto-formats!

share|improve this answer
    
This worked for one of my users that was upgraded from Office 2003 to Office 2010. This was apparently only a problem for MS Publisher. –  TheSavo Feb 14 '13 at 18:33
    
This also worked for me going from 2010 -> 2013. Thanks! –  Lyrical Feb 18 at 16:35

In Windows Explorer choose, Tools | Folder options. Next, select the File Types tab. Click the New button. Enter 'TSV' in the File Extension box, then OK. Next, click the Change... button, select the 'Select the program from a list' radio button, then click OK. When the dialog options, scroll to find Microsoft Excel, select it, then click OK. Finally, close the Folder Options dialog.

share|improve this answer
    
I'm using Windows 7, so no File Types tab. The equivalent is "Set Associations" under Control Panel, but eventually it ends up at the same Open With dialog where it doesn't let me choose Excel.EXE. I noticed that *.TSV isn't listed as an Excel file type in Excel's Save As dialog, so it doesn't seem to think it can handle that file type anymore. –  bwarner Dec 14 '11 at 15:01
    
You could use 'Tab Delimited Text', which uses the .TXT extension by default, then alter the extension to be .TSV. –  Craig Dec 14 '11 at 16:47

I tried the prior post but it didn't work, probably because HKCR\Applications\EXCEL.EXE\shell\open\command was previously empty in my registry.

But it inspired me to search the Registry for the field values containing the directory Office12 and replace all occurences with Office14 (except when in an Office12 directory) and that worked for me.

share|improve this answer
  1. Right-click on a file that you want to associate with Excel 2010
  2. chose open with
  3. Select Choose default program
  4. Select Always use the selected program to open this kind of file
    Note: Excel will not show up on the list
  5. You need to select Browse and copy & paste the following in to the bottom box where it says File name. Basically you are manually telling the computer where exactly the Excel.exe is.

    C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE

    Or if you have Excel installed in program files

    C:\Program Files\Microsoft Office\Office14\EXCEL.EXE

It's very strange because if you look in that folder in Explorer, the Excel.exe is not there. But yet if you reference it as if it is there, this solution works.

This solution also works for Excel 2013 but watch that you associate with a file such as:

C:\Program Files\Microsoft Office 15\root\office15\excel.exe

and not the .excelcnv.exe file (if present) which is to do with backward compatibility to legacy versions.

share|improve this answer

protected by slhck Sep 16 '13 at 14:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.